Results 1 to 5 of 5
  1. #1
    RC poster
    Join Date
    Jun 2013
    Posts
    9

    Mm2 problems help!

    So third mm2 smoked up, first one actually caught on fire! Has anyone else had this problem? Why is this happening?!

  2. #2
    RC Qualifier
    Join Date
    Aug 2013
    Location
    Corpus Christi, Texas
    Posts
    365
    What gearing were you running? And do you ever check temps on the esc?

  3. #3
    RC Turnbuckle Jr. Wolfslash16's Avatar
    Join Date
    Mar 2012
    Location
    Riverton Utah
    Posts
    4,383
    Your batteries could be shorting them out... When all three of them went bad, were you using the same battery?
    Sl2sh Slayer Summit Sl4sh Teton/Rally T-Maxx Pnde

  4. #4
    RC Turnbuckle Jr. rag6's Avatar
    Join Date
    Mar 2008
    Location
    PM me if ya wanna bash at Greenwood Bashplex in Pittsburgh PA
    Posts
    13,273
    Need melted carnage pics of the fired esc...

    The monster mamba is a pretty stout esc. Were you running 6s?
    Wanna bash at Greenwood Bashplex in Pittsburgh ???

  5. #5
    RC poster
    Join Date
    Jun 2013
    Posts
    9
    Used two 3s lipos all three times, gearing was setup so I can run high speeds 25 tooth pinion and 50 tooth spur. Strange thing is third one was smoking I shut it off as soon as possible and for funzies I tried it the other day and it still works! So I guess its all right who knows tho..

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •