Results 1 to 5 of 5

Thread: Smoked xl 2..5

  1. #1
    RC Qualifier
    Join Date
    Sep 2012
    Location
    sacramento, ca
    Posts
    742

    Smoked xl 2..5

    Well, I smoked an xl 2.5 today like the title say's. It's my son's car. Hooked up a 2s lipo, mashed around for about 30 seconds, and pooof smoke. It would have caught fire if I didn't disconnect the battery. Are these things not lipo compatable?
    addicted much....

  2. #2
    RC Champion
    Join Date
    Nov 2011
    Location
    North Central OH
    Posts
    1,047
    This one is for LiPo, need LVD
    http://traxxas.com/products/parts/escs/xl25lvd

  3. #3
    RC Qualifier
    Join Date
    Sep 2012
    Location
    sacramento, ca
    Posts
    742
    Thats the one I have. Wierd. Know what, now that I think of it. The packaging on my 2s and 3s lipo look the same. Maybe I accidently put the 3s on it. Whoops!
    addicted much....

  4. #4
    RC Champion
    Join Date
    Nov 2011
    Location
    North Central OH
    Posts
    1,047
    Quote Originally Posted by the finisher View Post
    Thats the one I have. Wierd. Know what, now that I think of it. The packaging on my 2s and 3s lipo look the same. Maybe I accidently put the 3s on it. Whoops!
    Did you set it for LiPo or run it in NiMh by accident?

    To activate Low-Voltage Detection (LiPo setting):
    1. Make sure the LED on the XL-2.5 is on and RED.
    2. Press and hold the EZ-Set button (the LED
    will turn off ) (A). After ten seconds, the
    motor will beep twice and the LED will
    shine GREEN. Release the button (B).
    3. Low-Voltage Detection is now ACTIVATED.
    To disable Low-Voltage Detection (NiMH setting):
    1. Make sure the LED on the XL-2.5 is on and GREEN.
    2. Press and hold the EZ-Set button (the LED
    will turn off ) (A). After ten seconds, the
    motor will beep three times and the LED
    will shine RED. Release the button (B).
    3. Low-Voltage Detection is now DISABLED.

  5. #5
    RC Qualifier
    Join Date
    Sep 2012
    Location
    sacramento, ca
    Posts
    742
    Yeah, the more I think about it, it might have been in nimh mode. My 2 year old was last to drive it. But I don't think that was the cause. It should be able to handle the voltage of a 2 cell even in nimh mode I believe. I was running my merv on 3s before I ran this one and think I got my batteries mixed up, accidentaly putting my 3s in there.
    addicted much....

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •