Results 1 to 34 of 34

Thread: Angry

  1. #1
    RC Qualifier
    Join Date
    May 2011
    Posts
    574

    Angry

    I am angry at Apple and Traxxas, not sure who I am madder at.

    Traxxas clearly states that TQI telemetry will work with an ipod touch 2nd generation. and technically its true, as long as you want to use an old out of date version with no chance of ever updatiing it. Sure wish I knew that before I ran out and bought an ipod 2nd gen. THANKS TRAXXAS!!

    Apple CLEARLY stopped making updates compatible with the 2nd gen in order to force consumers to buy the newer model. Its the same machine, no reason at all it couldnt be updated to the lastest version. They are making it obsolete on purpose. THANKS APPLE!!

    I have the ap on both a 2nd gen and 4th gen. gonna try em both out and report the diferances I notice.

  2. #2
    RC Racer
    Join Date
    Aug 2013
    Posts
    239
    Try deleting the app and re-installing it. The app store has asked me if I want to run an older version of Traxxas Link and it works with my iTouches without camera (not sure what generation this one is) as well as the the 1st iTouch that came out with camera (not sure what generation this one is, but its the next one after the one without camera)

  3. #3
    RC Qualifier
    Join Date
    May 2011
    Posts
    574
    As my original post states. I am aware that I can run an older version. And never get any updates. If I was aware of this, I would have bought a newer version ipod.

  4. #4
    RC Racer
    Join Date
    Aug 2013
    Posts
    239
    My bad, I didn't, completely process your post.

    Steve Jobs philosophy has always been that the apple devices are disposable and should be upgraded to get the latest features.

    Generally operating systems are married to available processor power at the time of development. Newer OS with more features require more processor power than can be provided by older systems. Hence the never ending cycle of upgrading PCs and devices every 2-3 years.

    In regards to the Traxxas app, it's all the same.... Old vs new. It displays voltage, temperature, and rpm. Speed is not accurate and will never be since its based on rpm and limited parameters that can be modified in terms of tire size and understanding drive ratio. Not much gained by updating at this point.

    I guess if you're running profiles and the DTS system then it would be important, but if interested in telemetry only, then using an old iPod for this with some music makes sense, reserving newer pods and phones for personal use.

    Current link won't charge my iPhone 4S off the TQi. Others have found traxxas link failing with iOS 7 and no update from Traxxas link. I figure if you have it working why break it by upgrading.

    Traxxas TQi will update its firmware and receivers and occasionally fail such that the entire thing with receiver has to be sent to Traxxas for them to diagnose their failure and mail you back a new one 2 weeks later at a cost of $12 to mail it too them and phone call for an RMA. The thing they send back is disassembled so you have to take the same risk of putting it together upgrading firmware and having it fail all over again. I turned off auto updates so I don't have to put up with this. Almost makes one want to use a different transmitter with sensors for better reliability than the QC provided by Traxxas.

    Oh and if you get the new iPhone 5 you now need a 30 pin to lightning adapter in order to make new idevices work with the TQi base. The new device now sticks out farther from the base.

    In the end, no clean solutions from Apple or Traxxas.
    Last edited by Dementor; 10-13-2013 at 04:32 PM.

  5. #5
    Marshal ksb51rl's Avatar
    Join Date
    Nov 2006
    Location
    Northern NJ
    Posts
    15,473
    So far as the receivers failing, I don't know what is happening.

    However, I don't see how Traxxas or even Apple is at fault for the OP's lack of research on devices or operating systems.
    Alt-248 on the number pad =

  6. #6
    RC Racer
    Join Date
    Aug 2013
    Posts
    239
    Actually its very difficult to get reliable information up front. Seems like one just has to buy the units and see if it works or not. Like Traxxas sells the parts for the trucks but doesn't always provide instructions on how to install or get the thing to work, we we have to spend much time perusing multiple forums or doing google searches trying to find info only to find that the available data dates back to 2009, 2010, 2011 and it is not always clear if something has been upgraded since then.

    ymmv

  7. #7
    RC Qualifier
    Join Date
    Dec 2011
    Location
    Washington State
    Posts
    625
    Ugh, I got a good one on this same note. I bought the TQi setup and all the sensors for one of my Traxxas vehicles and another vehicle I had, all worked like a charm. Only reason I went for it was that I already had an old iPhone 3g sitting there. Long story short, I no longer have the app anywhere and I can't download an old version. So I have a box that says it's good for this phone, but I can no longer get the app to USE the $100+ worth of stuff I bought and installed. Oh well, ebay ftw I guess as I'm not going to go blow $100-200 on a compatible iPod. I honestly blame Apple more than Traxxas for this one but it would be nice if a legacy version of the app was made available for those that bought the product when it was explicitly made with iOS 4.2.1 on the package as compatible.
    P2de VXL - Summit

  8. #8
    RC poster
    Join Date
    Jun 2013
    Posts
    1
    Quote Originally Posted by Dementor View Post
    Actually its very difficult to get reliable information up front. Seems like one just has to buy the units and see if it works or not. Like Traxxas sells the parts for the trucks but doesn't always provide instructions on how to install or get the thing to work, we we have to spend much time perusing multiple forums or doing google searches trying to find info only to find that the available data dates back to 2009, 2010, 2011 and it is not always clear if something has been upgraded since then.

    ymmv
    true true true

  9. #9
    RC poster
    Join Date
    Dec 2013
    Posts
    4
    Awesome I just ordered the tqi radio yesterday cause I have a 2nd gen ipod to save me 150 bucks from buying a radio with the screen built in. So now I find out I have to buy a new ipod? I sure hope not im gonna be upset

    Traxxas has a strict language policy. A word filter operates to change inappropriate words and banned websites or brands to *s. When you see these in your post, you MUST edit them out.
    -ksb51rl
    Last edited by ksb51rl; 12-12-2013 at 07:43 AM.

  10. #10
    Marshal ksb51rl's Avatar
    Join Date
    Nov 2006
    Location
    Northern NJ
    Posts
    15,473
    Quote Originally Posted by Moto x View Post
    Awesome I just ordered the tqi radio yesterday cause I have a 2nd gen ipod to save me 150 bucks from buying a radio with the screen built in. So now I find out I have to buy a new ipod? I sure hope not im gonna be upset
    Reports I have seen suggest that the gen2 iPod no longer works.
    Alt-248 on the number pad =

  11. #11
    RC poster
    Join Date
    Dec 2013
    Posts
    4
    That's just dazzy's!

  12. #12
    RC Enthusiast
    Join Date
    Sep 2013
    Posts
    35
    2nd Gen iPod Touch is no longer supported.. Frustrating! The software requires iOS 4.3 or higher. The 2nd Gen Touch only supports iOS 4.2.1

  13. #13
    RC Enthusiast
    Join Date
    Feb 2011
    Location
    North Carolina
    Posts
    41
    Quote Originally Posted by rvee86 View Post
    2nd Gen iPod Touch is no longer supported.. Frustrating! The software requires iOS 4.3 or higher. The 2nd Gen Touch only supports iOS 4.2.1
    This is the problem I have. My iPod doesn't have the camera. I am betting it is the 2nd Gen. I hooked it up to my iTunes and tried to update the iOS from 4.2.1 to the 4.3. It said my iOS is up to date and I have no option to upgrade. Guess I will be upgrading to a newer iPod......

  14. #14
    RC Racer
    Join Date
    Aug 2013
    Posts
    239
    Interesting. I have an iPod 2nd Generation running iOS 4.2.1 and was able to load Traxxas Link (app store asked me if I wanted to load an older version) and it works just fine. Slower than an iPod 3rd gen and iPhone 4s to start up, but works just the same.

  15. #15
    RC Qualifier
    Join Date
    May 2011
    Posts
    574
    I am also using an ipod touch 2nd gen that asked me if I wanted to use an older version of traxxas.

    It is posible that they no longer offer that older version.

  16. #16
    RC Enthusiast
    Join Date
    Feb 2011
    Location
    North Carolina
    Posts
    41
    Quote Originally Posted by Dementor View Post
    Interesting. I have an iPod 2nd Generation running iOS 4.2.1 and was able to load Traxxas Link (app store asked me if I wanted to load an older version) and it works just fine. Slower than an iPod 3rd gen and iPhone 4s to start up, but works just the same.
    Quote Originally Posted by knall View Post
    I am also using an ipod touch 2nd gen that asked me if I wanted to use an older version of traxxas.

    It is posible that they no longer offer that older version.
    I just got mine to work on my 2nd gen. I downloaded the app onto my iTunes and installed it on my iPod. It too asked if I wanted to run an older version. It works pretty well for me now.

  17. #17
    Marshal ksb51rl's Avatar
    Join Date
    Nov 2006
    Location
    Northern NJ
    Posts
    15,473
    If reports are accurate, this asking whether you'd like to run an older version is a new occurrence. It seems the good people at Traxxas are listening since I don't see the App Store doing this without some prompting.
    Alt-248 on the number pad =

  18. #18
    RC Enthusiast
    Join Date
    Feb 2011
    Location
    North Carolina
    Posts
    41
    Sounds good to me! It may still have bugs, but at least it is working on the older iOS.

  19. #19
    RC Racer
    Join Date
    Aug 2013
    Posts
    239
    I downloaded mine off of wifi without having to connect 2nd gen iTouch to the computer. However, once you've got the app on your computer, it will be easier to reload it to multiple 2nd gen iTouches which is what I also do -- telemetry on Summit and Slash and ERBE.

    I turn off wifi and try not to use my phone because of apparent reports that an incoming call or message and nearby wifi may mess up the TQi.

  20. #20
    RC Racer
    Join Date
    Dec 2013
    Posts
    190
    Quote Originally Posted by rvee86 View Post
    2nd Gen iPod Touch is no longer supported.. Frustrating! The software requires iOS 4.3 or higher. The 2nd Gen Touch only supports iOS 4.2.1
    Just buy a used iPhone 4 or 4s. A perfect 4 can be had for $150 and a perfect 4S is $200.

  21. #21
    RC Racer
    Join Date
    Aug 2013
    Posts
    239
    iTunes store seems to be keeping old copies of software so those with older no longer upgradable ipods can still download compatible vs of software.

  22. #22
    RC Enthusiast
    Join Date
    Sep 2013
    Posts
    35
    Quote Originally Posted by mkimmer99 View Post
    I just got mine to work on my 2nd gen. I downloaded the app onto my iTunes and installed it on my iPod. It too asked if I wanted to run an older version. It works pretty well for me now.
    I'm going to have to give this a shot. Thanks for the tip! -- I hope it works!

  23. #23
    RC Enthusiast
    Join Date
    Sep 2013
    Posts
    35
    Quote Originally Posted by rvee86 View Post
    I'm going to have to give this a shot. Thanks for the tip! -- I hope it works!
    Just wanted to give you guys an update.. I was able to get it to work! What I did was first downloaded the app using the app store on my computer. Then, logged into the App Store on my iPod Touch 2G. Tried to download the app, and was presented with the prompt asking if I wanted to download the most recent compatible version. -- Works fine too, was getting telemetry from my Jato (70 degrees, battery reading, etc.)

    Glad I kept up with this thread! Saved me a needless purchase. -- Now I'm inspired to install telemetry into my Raptor!

  24. #24
    RC Racer
    Join Date
    Aug 2013
    Posts
    239
    I keep older versions of apps on my computer so they can be reloaded onto older no longer really supported iTouches and pads running iOS 4 and iOS 5. Some old software just plain disappears from the apps store, so keeping the old one on the computer gives me a retrievable backup.

  25. #25
    RC Racer
    Join Date
    Feb 2014
    Posts
    171
    Quote Originally Posted by rvee86 View Post
    Just wanted to give you guys an update.. I was able to get it to work! What I did was first downloaded the app using the app store on my computer. Then, logged into the App Store on my iPod Touch 2G. Tried to download the app, and was presented with the prompt asking if I wanted to download the most recent compatible version. -- Works fine too, was getting telemetry from my Jato (70 degrees, battery reading, etc.)

    Glad I kept up with this thread! Saved me a needless purchase. -- Now I'm inspired to install telemetry into my Raptor!
    Just got an Ultimate and tried to setup the TQI with an old iPhone 3G. Was hoping the above would work - NO GO.
    Anybody setup a TQI with an out of date IPHONE/IPOD and get it to work since FEB?

    Seems like it's on Traxxas' end if the 'INSTALL OLDER VERSION' option is not coming up anymore. Read about the option for app developers here:
    http://www.theverge.com/2013/9/17/47...ibility-prompt

    Not sure if anything has changed on Apple's end for this policy.

    RVEE86's post is only from 2 weeks ago; so I'm hoping it's just me missing a check box or something. Would suck if this 'install older version' workaround just stopped working now.
    Last edited by 1esotericguy; 02-10-2014 at 03:10 PM.

  26. #26
    RC Qualifier
    Join Date
    Apr 2012
    Location
    Michigan
    Posts
    399
    Just setup Traxxas Link last night on my Ipod 2nd gen. Had to download the older version. It didn't work at first, but messed around with it a bit after seeing this thread and got it. Thank goodness. Almost thought I wasted my money.
    Big Air Don't Care

  27. #27
    RC Competitor
    Join Date
    Mar 2014
    Location
    Carmel, IN.
    Posts
    75
    I had same issue yesterday with a 2nd Gen. I synced the I touch with my PC updated it from IOS 4.2 to 4.3 and it now works. Its not Traxxas or apples fault. You need to Update it thru ITunes. IOS is the operating sytem
    Your not having fun unless you break it!

  28. #28
    RC Competitor
    Join Date
    Mar 2014
    Location
    Carmel, IN.
    Posts
    75
    For those of you with a Gen 2 Use the USB cable download Itunes latest and it will upgrade to the newer software. I was just as frustrated as anyone but finally figured it out. From 4.2 to 4.3
    Your not having fun unless you break it!

  29. #29
    RC poster
    Join Date
    Mar 2014
    Posts
    3
    Guys I have a 2nd Gen Ipod. This app will work with persistence! using 4.2.1 iOS
    1. How I did it was first downloaded the app though the app store on my PC. Without the Ipod being connected.
    2. Then tried installing onto the Ipod with it connected. It said "can not download due to your Ipod software being out of date blah blah"
    3. Unplugged it! (gave up on it, swore etc etc)
    4. Came back about 20min later to try again. STILL UNPLUGGED. Went into the App store using wifi on the ipod, clicked install and prompted me to install the latest version to work with the old iOS.

    So it seems like you have to download the app onto your PC/ Itunes account on you PC. Then access the app and install it using the Ipod app store (having the Ipod unplugged from your PC at the time of install).

    Good luck

  30. #30
    RC Qualifier
    Join Date
    May 2011
    Posts
    574
    Quote Originally Posted by TRX_RC_ADDIC View Post
    I had same issue yesterday with a 2nd Gen. I synced the I touch with my PC updated it from IOS 4.2 to 4.3 and it now works. Its not Traxxas or apples fault. You need to Update it thru ITunes. IOS is the operating sytem

    Oh man..... U sure about that ? Now I wanna giveit a try just for other apps....... I am running LINK w the older version IOS but cant do anything else w the ipod 2nd. gen.

  31. #31
    RC poster
    Join Date
    May 2014
    Posts
    10
    I realized my iPod tough 2G wouldn't work either, so I grabbed a 4th gen iPod touch for $100.00 and all is well with the world. I absolutely love the Traxxas Link app. It's very well written and you can tell the developers put a lot of time into creating it.

  32. #32
    RC poster
    Join Date
    Apr 2011
    Location
    Michigan!
    Posts
    7
    Hi all, I bought an E-Maxx Brushless Edition model 3908 and it came with the 2 channel TQi with docking base. I plugged my iPhone 3GS into it and it worked for about 5 minutes and started auto updating my transmitter. After the update my transmitter no longer recognizes my phone. I tried installing an older version of the app like Traxxas recommended and I found that I had not yet updated it in my itunes so I installed version 3.1.0 and it still does not recognize my phone. I get "This Device Is Not Supported By iPhone" error. I called Traxxas and they told me it was Apples fault and I called Apple and they said it's Traxxas' fault. False advertising is false advertising regardless of the situation. I have filed a complaint with the B.B.B. Anybody else feel ripped off?
    Revo 3.3 / TMaxx 2.5 / Savage X 4.6

  33. #33
    RC poster
    Join Date
    Jun 2014
    Location
    Kirkland Washington
    Posts
    18
    I used it win an Iphone 4 (not mine obviously) without any problems even after the update... They need to hurry up and bring it to android. Apple sucks!

  34. #34
    RC Qualifier
    Join Date
    Aug 2013
    Location
    Brazoria, Texas
    Posts
    769
    Quote Originally Posted by Supamegaman View Post
    I used it win an Iphone 4 (not mine obviously) without any problems even after the update... They need to hurry up and bring it to android. Apple sucks!

    Or windows.... Lumia 1520 for da win.
    Revo 2.5 upgraded to 3.3.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •