Results 1 to 9 of 9

Thread: lipo balancing

  1. #1
    RC Competitor
    Join Date
    Aug 2009
    Posts
    83

    lipo balancing

    just started using lipo batterys ive charged mine prob 2-3 times balancing every time and when done i check the balance its been 4.20 except this time it was 4.20 and 4.16 is this bad or is that close enough

  2. #2
    RC Turnbuckle Jr. JimmyNeutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, Michigan
    Posts
    12,291
    They should be closer than that... either the charger timed out, reached capacity cut-off, isn't balancing the pack properly, or the pack has something wrong with it.

    Which batteries are you using?
    What RC are they in?
    What charger is it?
    Whatever it is I just typed... could be wrong.

  3. #3
    RC Competitor
    Join Date
    Aug 2009
    Posts
    83
    using venom 2s 5000 mah and a venom pro 2 charger charging at 5 amps in balance mode running in a slash 4x4

  4. #4
    Marshal ksb51rl's Avatar
    Join Date
    Nov 2006
    Location
    Northern NJ
    Posts
    15,986
    Quote Originally Posted by Jimmie Neutron View Post
    They should be closer than that... either the charger timed out, reached capacity cut-off, isn't balancing the pack properly, or the pack has something wrong with it.

    Which batteries are you using?
    What RC are they in?
    What charger is it?
    Yup. Or the charger voltage sensor has a fault. (Least likely of the possibilities.)
    Alt-248 on the number pad =

  5. #5
    RC Competitor
    Join Date
    Aug 2009
    Posts
    83
    i hope not the chargers brand new 2nd one i owned first one i plugged in the wall and it blew up instantly

  6. #6
    Marshal ksb51rl's Avatar
    Join Date
    Nov 2006
    Location
    Northern NJ
    Posts
    15,986
    Quote Originally Posted by zx809 View Post
    i hope not the chargers brand new 2nd one i owned first one i plugged in the wall and it blew up instantly
    And you bought (or accepted) a replacement...
    Good thing about Venom electronics and electrics: they have a very liberal replacement policy.
    Bad thing about Venom electronics and electrics: you'll need to use the liberal replacement policy.
    Alt-248 on the number pad =

  7. #7
    RC Qualifier
    Join Date
    Oct 2010
    Location
    NJ
    Posts
    779
    ^^ lol. You just can't go cheap on batteries and chargers.

  8. #8
    RC Competitor
    Join Date
    Aug 2009
    Posts
    83
    there trying to tell me the battery is no good? i think its the charger

    it did say bad connection when i first plugged it in
    Last edited by Double G; 09-28-2013 at 11:25 PM. Reason: merge

  9. #9
    RC Turnbuckle Jr. JimmyNeutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, Michigan
    Posts
    12,291
    It could be either.
    It could be that the balance connector is dirty.
    Whatever it is I just typed... could be wrong.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •