Results 1 to 15 of 15
  1. #1
    RC Qualifier
    Join Date
    Aug 2012
    Location
    Alberta Canada
    Posts
    896

    Revo 3.3 TQi Trottle and Shift channel not working

    Ok so i've never had this problem before its like the RX or TX is not working. The throttle and shift servos do not work, but if you plug them into the steering then the steering operates them no problem at all. Is there something to fix or will i need a new radio system.

  2. #2
    RC Racer
    Join Date
    Mar 2013
    Location
    Australia, vic
    Posts
    137
    Did you happen to put an iPhone on the dock before this happened?

    Sent from my GT-I9300T using Tapatalk 2

  3. #3
    RC Qualifier
    Join Date
    Aug 2012
    Location
    Alberta Canada
    Posts
    896
    Its not a telemetry truck. It is 2.4gz with opti drive.

    I un hooked the opti and used a different radio system to get the truck running

    Sent from my SGH-I317M using Tapatalk 2

  4. #4
    RC Qualifier
    Join Date
    Jun 2011
    Location
    Copple Crown Mountain
    Posts
    391
    Try it with the Stock radio now. Most take the opti-drive out because of the issues with it. If you don't go FOC, be careful, come to a complete stop before shifting.

  5. #5
    RC Qualifier
    Join Date
    Aug 2012
    Location
    Alberta Canada
    Posts
    896
    i tried with the opti drive removed, I guess with the Opti drive removed you need or should use the tekno RX box kit,

  6. #6
    RC Qualifier
    Join Date
    Aug 2012
    Location
    Alberta Canada
    Posts
    896
    Does the opti drive help with shifting? I thought it was only for reverse. I was going to remove the reverse but my revo came with telemetry already installed

    Posted by my Galaxy Note 2

  7. #7
    RC Qualifier
    Join Date
    Jun 2011
    Location
    Copple Crown Mountain
    Posts
    391
    The opti is a "fail safe" that wont allow the Revo to shift, forward & reverse, until it is stopped and idling. You can still get the FOC kit and remove opti-drive.

  8. #8
    RC Racer
    Join Date
    Sep 2012
    Location
    somewere in ohio bashing a traxxas
    Posts
    154
    what is the FOC kit?????????????

  9. #9
    RC Racer
    Join Date
    Mar 2013
    Location
    Australia, vic
    Posts
    137
    Forward only conversion

    Sent from my GT-I9300T using Tapatalk 2

  10. #10
    RC Racer
    Join Date
    Sep 2012
    Location
    somewere in ohio bashing a traxxas
    Posts
    154
    oh okay i gues that makes it faster??????????

  11. #11
    RC Qualifier
    Join Date
    Jun 2011
    Location
    Copple Crown Mountain
    Posts
    391
    Maybe a bit faster. Less weight.

  12. #12
    RC Enthusiast
    Join Date
    Sep 2013
    Posts
    28
    I'm having the same problem..but I removed the opti and put my throttle servo directly into chan 2 to test it...No bueno. But my hitec server will work in steering channel.

  13. #13
    RC Enthusiast
    Join Date
    Sep 2013
    Posts
    28
    Alright well I got my engine setup to replace the 3.3. The pipe came in yesterday and now only the receiver problems are holding me back...

  14. #14
    RC Enthusiast
    Join Date
    Sep 2013
    Posts
    28
    Called Traxxas support because I attempted to reset my throttle servo settings etc via the radio controls and throttle still did not work. So I'm sending my radio sys and optidrive in for testing.

  15. #15
    RC Competitor
    Join Date
    Sep 2013
    Posts
    74
    Hello Sgt., I like your set-up there I have two of those engines here that have been sitting a few years and need to be disassembled and cleaned and I was wondering if you knew of a supplier for parts such as wrist pins, and circlips for these guys?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •