Results 1 to 8 of 8

Thread: twitchy servo

  1. #1
    RC Qualifier
    Join Date
    Apr 2013
    Posts
    368

    twitchy servo

    I was running my spartan today and hooked a fresh pack of lipos up after the first run and my servo was twitchy. It was like it was vibrating and buzzing. I messed with the trim on the tx and it kinda helped... I also noticed that the servo was kinda moving slow....
    Whats the issue?
    Im using tqi tx/rx
    stock servo
    Is there an upgrade servo if needed?

  2. #2
    RC Racer
    Join Date
    Jun 2013
    Location
    Corona,CA
    Posts
    110
    I had the same problem. I replaced the servo, and its been fine since. I'm not sure if this link will work, but check out my old thread. http://traxxas.com/forums/showthread...49-Little-help

  3. #3
    RC Qualifier
    Join Date
    Apr 2013
    Posts
    368
    Thanks!!!!

  4. #4
    RC Qualifier
    Join Date
    Jun 2011
    Posts
    374
    A little amount of water in the servo can cause this. you can take them apart and dry them out. When taking them apart there are a couple of lock tabs inside you have to release. I seal the wires and the screws with black liquid electrical tape and this keeps them totally waterproof.

  5. #5
    RC Qualifier
    Join Date
    Jul 2013
    Posts
    580
    I have had the same problem after I flipped my boat, I assume it's caused my moisture inside. I run in Salt water and ONLY saltwater so my boat is a bit more used than others. I just replace them, I have about 3 new ones on hand so anytime anywhere.

  6. #6
    RC Qualifier
    Join Date
    Jun 2011
    Posts
    374
    Quote Originally Posted by Spartanator View Post
    I have had the same problem after I flipped my boat, I assume it's caused my moisture inside. I run in Salt water and ONLY saltwater so my boat is a bit more used than others. I just replace them, I have about 3 new ones on hand so anytime anywhere.
    Add the liquid electrical tape and you will not have to replace them again

  7. #7
    RC Qualifier
    Join Date
    Apr 2013
    Posts
    368
    Quote Originally Posted by SJS View Post
    Add the liquid electrical tape and you will not have to replace them again
    Where do I add it??

  8. #8
    RC Qualifier
    Join Date
    Jun 2011
    Posts
    374
    the water leaks in through the wires so coat the wires and the black rubber boot the wires pass through. I also put some on the screw heads on the servo bottom.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •