Results 1 to 14 of 14
  1. #1
    RC Racer
    Join Date
    Sep 2012
    Posts
    238

    Easy peak plus error message

    Charging two 2s 5000mah 30c packs. One chargers to full, the other to the same voltage, but get an error. The error reads :

    Battery Vol Err
    Cell High Vol

    Bad pack?

  2. #2
    RC Turnbuckle Jr. Jimmie Neutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, MI
    Posts
    12,281
    What are the cell voltages?

    There are a few ways to check... with a multimeter and with a cell checker.
    If you don't have either, a cell checker can be bought for less than $5 and I feel it should be in every electric RC'rs tool box.
    Whatever it is I just said... I could be wrong.

  3. #3
    RC Racer
    Join Date
    Sep 2012
    Posts
    238
    I'll check. Think I have a bad pack, the other charges fine.

  4. #4
    RC Racer
    Join Date
    Sep 2012
    Posts
    238
    3.71 and 3.75

  5. #5
    RC Turnbuckle Jr. Jimmie Neutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, MI
    Posts
    12,281
    Those are not too high... 3v/cell is lowest, 4.2v/cell is highest.

    Could be a dirty balance connector causing the issue.

    I wouldn't jump to bad pack with those normal and 100% acceptable cell voltages.
    Whatever it is I just said... I could be wrong.

  6. #6
    RC Racer
    Join Date
    Sep 2012
    Posts
    238
    But my other pack charges fine, that's what I don't get.

  7. #7
    RC Turnbuckle Jr. Jimmie Neutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, MI
    Posts
    12,281
    Quote Originally Posted by Jimmie Neutron View Post
    Those are not too high... 3v/cell is lowest, 4.2v/cell is highest.

    Could be a dirty balance connector causing the issue.

    I wouldn't jump to bad pack with those normal and 100% acceptable cell voltages.
    Have you cleaned this yet?
    Whatever it is I just said... I could be wrong.

  8. #8
    RC Racer
    Join Date
    Sep 2012
    Posts
    238
    Taken a brush and cleaned them out. Still same issue. Guess could be connector on that one pack?

    Galaxy Tab2
    USAF, Retired
    ERBE, Dewalt EMaxx, Rustler VXL

  9. #9
    RC Racer
    Join Date
    Nov 2012
    Posts
    220
    I would try switching what side the batteries are connecting to the charger on, this way you could narrow it dow to a battery or a charger issue.

  10. #10
    RC Racer
    Join Date
    Sep 2012
    Posts
    238
    No choice there, only connects to one side. The second pack charges fine, doesn't make since

  11. #11
    RC Turnbuckle Jr. Jimmie Neutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, MI
    Posts
    12,281
    Very well could be a balance connector/cable issue... it would take someone with pretty good soldering skills to open the pack up to fix it. I have done it before; it would almost be cheaper to get a new pack. The cost of the connector, tough tape, and shrink ended up being almost have the cost of the pack I was fixing after shipping and taxes. But I did get enough materials to do 4 packs or so... with the smallest purchasable quantities of each item.
    Whatever it is I just said... I could be wrong.

  12. #12
    RC Racer
    Join Date
    Sep 2012
    Posts
    238
    Thank everyone for the help. I've ordered a new pack

    Galaxy Tab2
    USAF, Retired
    ERBE, Dewalt EMaxx, Rustler VXL

  13. #13
    RC Racer
    Join Date
    Nov 2012
    Posts
    220
    Sorry i think I misunderstood, thought it was a dual pack charger

  14. #14
    Marshal Double G's Avatar
    Join Date
    May 2008
    Location
    Putting the water on the hot stuff
    Posts
    9,707
    Since Traxxas does not appear to make this battery, this is closed.
    The Super Derecho

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •