Results 1 to 32 of 32
  1. #1
    RC Racer
    Join Date
    Jul 2013
    Posts
    175

    Batteries done forever???????????

    I go out to go try out my awesome new track I just finished"remodeling" and when I plug my battery into the truck and pressed the throttle. When I got to full throttle, it drove like I was only holding half throttle. This happened with both of my NIMH batteries. I pulled out my volt meter and both batteries pulled 10 volts. I've only had my truck for 6 months so I doubt my motor or ESC could be fried.I rrrreeeeaaallllllyyyyyyy wanted to try out my new track.

  2. #2
    RC Qualifier
    Join Date
    Apr 2012
    Location
    McKinney, Texas
    Posts
    811
    WoW I'm sorry about your bashing session not falling thru. Are you in training mode by any chance? If your truck is running at half throttle that maybe why so check on what mode you're in and hopefully you're in training mode so the issue will be fixed once you put it in sports mode.

  3. #3
    RC Turnbuckle Jr. Wolfslash16's Avatar
    Join Date
    Mar 2012
    Location
    Riverton Utah
    Posts
    4,351
    Check and see if you esc is in lipo mode. That would slow it down quite a bit.
    Sl2sh Slayer Summit Sl4sh Teton/Rally T-Maxx Pnde

  4. #4
    RC Qualifier
    Join Date
    Apr 2012
    Location
    McKinney, Texas
    Posts
    811
    Quote Originally Posted by Wolfslash16 View Post
    Check and see if you esc is in lipo mode. That would slow it down quite a bit.
    So her pede will still run while she is using nimh and lips while in lipo mode? If so I didnt know that

  5. #5
    RC Racer
    Join Date
    Jul 2013
    Posts
    175
    Quote Originally Posted by Wolfslash16 View Post
    Check and see if you esc is in lipo mode. That would slow it down quite a bit.
    Had that problem before. Truck moved inches. Recalibrated it and it was fine. Did the same thing now and it did nothing.

  6. #6
    RC Racer
    Join Date
    Jul 2013
    Posts
    175
    Quote Originally Posted by jtalaue View Post
    WoW I'm sorry about your bashing session not falling thru. Are you in training mode by any chance? If your truck is running at half throttle that maybe why so check on what mode you're in and hopefully you're in training mode so the issue will be fixed once you put it in sports mode.
    How?

    I will answer all comments in the morning. Bedtime for me. Thanks!

  7. #7
    RC Qualifier
    Join Date
    Apr 2012
    Location
    McKinney, Texas
    Posts
    811
    Quote Originally Posted by judy2383 View Post
    How?

    I will answer all comments in the morning. Bedtime for me. Thanks!
    Scroll down to page 18

    http://traxxas.com/sites/default/fil...0-121112_0.pdf

  8. #8
    RC Competitor
    Join Date
    Jul 2013
    Posts
    63
    perfect time to go lipo! dont hold back!
    Quote Originally Posted by judy2383 View Post
    I go out to go try out my awesome new track I just finished"remodeling" and when I plug my battery into the truck and pressed the throttle. When I got to full throttle, it drove like I was only holding half throttle. This happened with both of my NIMH batteries. I pulled out my volt meter and both batteries pulled 10 volts. I've only had my truck for 6 months so I doubt my motor or ESC could be fried.I rrrreeeeaaallllllyyyyyyy wanted to try out my new track.

  9. #9
    RC Racer
    Join Date
    Jul 2013
    Posts
    175
    Quote Originally Posted by 550puggy View Post
    perfect time to go lipo! dont hold back!
    Was thinking about that, but I want to be able to have three batteries so I can have longer runs.

  10. #10
    RC Racer
    Join Date
    Jul 2013
    Posts
    175
    Quote Originally Posted by judy2383 View Post
    Was thinking about that, but I want to be able to have three batteries so I can have longer runs.
    Actually.....what type of 2s LIPO battery do you guys suggest I get?

  11. #11
    RC Racer
    Join Date
    Jul 2013
    Posts
    175
    Ok. So I just changed my truck to sport mode, and it did nothing. I did the whole throttle adjustment thing did nothing. Batteries are fully charged and everything is calibrated, what is going on?!?

  12. #12
    RC Champion
    Join Date
    Nov 2012
    Posts
    1,162
    when is the last time u cleaned the motor.. sounds like a motor issue.. my little ones rusty is doing the same thing after she used a full bottle of cleaner on the motor.. i can squirt it with water and it will run fine until it dries..

  13. #13
    RC Racer
    Join Date
    Jul 2013
    Posts
    175
    Thanks for the reply. So you think I might need to clean the motor? Do I just clean it once and it will be good for a while? And how would I get into the motor?

  14. #14
    RC Turnbuckle Jr. spenniepoos's Avatar
    Join Date
    Apr 2012
    Location
    Wales in the UK
    Posts
    5,222
    You can buy the traxxas rebuild kit for the velineon motor part number 3352 you just need to check out some vids on youtube that will help get into the motorhope that helps dude.............peace
    Famous last words...watch this!!!!

  15. #15
    RC Turnbuckle Jr. Wolfslash16's Avatar
    Join Date
    Mar 2012
    Location
    Riverton Utah
    Posts
    4,351
    Wait, is your truck brushed, or brushless?
    Last edited by Wolfslash16; 07-26-2013 at 12:07 PM.
    Sl2sh Slayer Summit Sl4sh Teton/Rally T-Maxx Pnde

  16. #16
    RC Racer
    Join Date
    Jul 2013
    Posts
    175
    Quote Originally Posted by Wolfslash16 View Post
    Wait, is your truck brushed, or brushless?
    Brushless, why?

  17. #17
    RC Racer
    Join Date
    Jul 2013
    Posts
    175
    Quote Originally Posted by spenniepoos View Post
    You can buy the traxxas rebuild kit for the velineon motor part number 3352 you just need to check out some vids on youtube that will help get into the motorhope that helps dude.............peace
    Would I just be better off buying a new motor and ESC, the same setup you have?

  18. #18
    RC Turnbuckle Jr. spenniepoos's Avatar
    Join Date
    Apr 2012
    Location
    Wales in the UK
    Posts
    5,222
    Unless its still covered by traxxas and they will replace it for you or look on funshobby at the combos they have or see if you can get a good deal on the castle sct race pro 3800kv with the 5 mm shaft all are good setups without costing the earth.....peace
    Famous last words...watch this!!!!

  19. #19
    RC Racer
    Join Date
    Jul 2013
    Posts
    175
    Thanks, I don't no if I should do it just because I still think it could be battery failure.


    Does anyone know the symptoms of battery failure?

  20. #20
    RC Turnbuckle Jr. spenniepoos's Avatar
    Join Date
    Apr 2012
    Location
    Wales in the UK
    Posts
    5,222
    Take it to lhs and see if they could test it with a different lipo for you and take it from there......peace
    Famous last words...watch this!!!!

  21. #21
    RC Racer
    Join Date
    Jul 2013
    Posts
    175
    What is lhs, and I have NiMh, but it would work either way I think.

  22. #22
    RC Qualifier
    Join Date
    May 2011
    Posts
    396
    Is your esc light green or red when you turn it on? LHS = local hobby shop.

  23. #23
    RC Turnbuckle Jr. spenniepoos's Avatar
    Join Date
    Apr 2012
    Location
    Wales in the UK
    Posts
    5,222
    Local hobby store and see if it is the battery that is going a bit crazy and if its not give traxxas a phone call and see what they say.....peace
    Famous last words...watch this!!!!

  24. #24
    RC Champion
    Join Date
    Nov 2012
    Posts
    1,162
    Woops I thought u were running brushed. Ignore my previous post. Still sounds like a motor or esc issue to me you have run 2 different batteries and have the same issue with both. Have you tryed resetting everything back to stock? Also is it possible that your multi function knob got moved or your 50/50 70/30 switch got moved from what it was originally?


    Sent from my iPhone using Tapatalk 2

  25. #25
    RC Qualifier
    Join Date
    Apr 2012
    Location
    McKinney, Texas
    Posts
    811
    Quote Originally Posted by judy2383 View Post
    Would I just be better off buying a new motor and ESC, the same setup you have?
    Motor and ESC are covered under lifetime warranty and it will only cost you a total of $40 to get the motor repaired and $55 for the ESC. I do suggest bringing your PEde to your LHS and see if they can find out if it's the motor/ESC that's an issue then you can go forward and get it repaired by traxxas. And if your LHS is like mine when I had issues with my stock motor they removed the motor and ESC and tried them on a used one they had lying around to see if it was the motor or ESC but if they wont help you then you'll have to find out if the motor/ESC is the issue. Good luck!

    http://traxxas.com/support/Traxxas-L...onics-Warranty
    Last edited by jtalaue; 07-26-2013 at 01:41 PM.

  26. #26
    RC Racer
    Join Date
    Jul 2013
    Posts
    175
    Quote Originally Posted by Jeff_G View Post
    Is your esc light green or red when you turn it on? LHS = local hobby shop.
    Red, if it was green I would be in LiPO.

  27. #27
    RC Racer
    Join Date
    Jul 2013
    Posts
    175
    Just finally got around to calling my lhs, and they said that if I call them when I have just left my house, that they would charge a 2s LiPO for me and since I live so far away it would be charged by the time I get it. When I get to the lhs I will be able to see if it is just my batteries. So I will be going down there either Friday, Saturday or Sunday to FINALLY find out.

  28. #28
    RC Turnbuckle Jr. spenniepoos's Avatar
    Join Date
    Apr 2012
    Location
    Wales in the UK
    Posts
    5,222
    I hope you get good news bro .......peace

    Spencer
    Famous last words...watch this!!!!

  29. #29
    RC Racer
    Join Date
    Jul 2013
    Posts
    175
    Quote Originally Posted by spenniepoos View Post
    I hope you get good news bro .......peace

    Spencer
    So do I, so do I.

  30. #30
    RC Racer
    Join Date
    Jul 2013
    Posts
    175
    Guess what? I was just about to go to the lhs and when I picked up the remote I noticed the throttle trim wasn't at 100%. So I turned throttle trim to 100% and plugged a battery in and Pede lives again! I just cannot believe I did not see that before.
    So I will be getting you guys that video today or tomorrow.

  31. #31
    RC Turnbuckle Jr. spenniepoos's Avatar
    Join Date
    Apr 2012
    Location
    Wales in the UK
    Posts
    5,222
    That's awesome dude now go bash your truck like you stole it ......peace
    Famous last words...watch this!!!!

  32. #32
    RC Racer
    Join Date
    Jul 2013
    Posts
    175
    I already drive it like its a stolen Toyota, but today I drive it like its a stolen Lambourghini

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •