Results 1 to 10 of 10

Thread: esc wont work

  1. #1
    RC Competitor
    Join Date
    Sep 2012
    Location
    cold lake,AB
    Posts
    65

    Unhappy esc wont work

    i turn the transmitter on and turn the esc on and it lights up but when i touch the throttle it doesnt do anything it i used it once before my servo blew and i just got that in and it doesnt work either any ideas on what it could be

  2. #2
    RC Champion
    Join Date
    Mar 2001
    Location
    Spring valley mn
    Posts
    1,135
    When you say your servo blew, what did it do? It could have taken out the BEC circuit in the ESC.
    My tranny case is stock :D

  3. #3
    RC Competitor
    Join Date
    Sep 2012
    Location
    cold lake,AB
    Posts
    65
    i just hit a tree and the plastic gears were shattered in the servo
    and i got the got2gorc motor combo

  4. #4
    RC Champion
    Join Date
    Mar 2001
    Location
    Spring valley mn
    Posts
    1,135
    Are you getting any lights on the receiver?
    My tranny case is stock :D

  5. #5
    RC Competitor
    Join Date
    Sep 2012
    Location
    cold lake,AB
    Posts
    65
    it turns red when i turn it on and the it shuts off

  6. #6
    RC Competitor
    Join Date
    Sep 2012
    Location
    cold lake,AB
    Posts
    65
    but the esc runs
    just the motor doesnt do anything

  7. #7
    RC Turnbuckle Jr. Jimmie Neutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, MI
    Posts
    12,280
    How do you know the ESC is running if the motor is not doing anything?
    Have you tried unplugging the servo to see if the motor/ESC works with it unplugged?
    Whatever it is I just said... I could be wrong.

  8. #8
    RC Competitor
    Join Date
    Sep 2012
    Location
    cold lake,AB
    Posts
    65
    the esc turns on cuz the lights are on and the built in fan turns on but the motor doesnt run idk what is wrong the motor and esc are brand new and same with the servo i got. the servo is a ******* 390 and i got the motor from got2gorc the same motor and esc that 50togo has.
    and i did try unplugging the servo and still doesnt work the servo doesnt work either

  9. #9
    RC Qualifier
    Join Date
    Oct 2008
    Location
    Soldotna, Alaska
    Posts
    730
    Check if the esc wire is properly plugged into the receiver.

    Also check the motor to esc wire connections.

    Sent from my SCH-R760 using Tapatalk 2
    Using while stupid may cause serious injury.

  10. #10
    RC Competitor
    Join Date
    Sep 2012
    Location
    cold lake,AB
    Posts
    65
    thx i had the wires to the receiver in the wrong way its hard to tell because the plug doesnt have that notch that goes into the slot of the receiver but it works now

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •