Results 1 to 8 of 8
  1. #1
    RC Qualifier
    Join Date
    Apr 2013
    Posts
    368

    Summit doesnt turn very well.

    I got a used summit vxl and it doesnt turn very well to one way. I tried to adjust the camber/toe and now i just made it worse. I moved the horn on the servo also. The servo is working, the steering is just not throwing for some reason... Please help me

  2. #2
    RC Champion
    Join Date
    Jul 2012
    Location
    Yakima, Washington
    Posts
    1,420
    I have had that happen with the stock servo, turns out it had some stripped gears on one side.
    With great brushless comes great responsibility.

  3. #3
    RC Qualifier
    Join Date
    Apr 2013
    Posts
    368
    Really? dang. The person I bought it from said it has a new servo...

    btw how u doin revoman78?..I got another converted e revo, erevo vxl and summit vxl now to keep the e revo you sold me company. I understand why you like the minis now lol

  4. #4
    RC Competitor
    Join Date
    Jun 2012
    Location
    Where the Summit takes me.
    Posts
    59
    Since I'm a beginner at RC, I may not know much, but I have already had to replace servo gears and one entire servo. There might be gunk and grime in the servo or gears could be stripped.
    1/16 Blue Summit
    "It's life, not drama." -Me

  5. #5
    RC poster
    Join Date
    Oct 2012
    Posts
    12
    Make sure the pillow balls can move freely in the axle carriers. Do you have RPM axle carriers? If you do than check that the small screws are not to tight. The ones that hold the pillow ball socket together. Another thing, if you don't have it already, try replacing the bushing on the servo saver with ball bearings. It might help. I know when I did that upgrade on mine it made the steering way smoother and more precise.

  6. #6
    RC Enthusiast
    Join Date
    Aug 2013
    Posts
    23
    try oiling it. I had the same problem

  7. #7
    RC Qualifier
    Join Date
    Apr 2013
    Posts
    368
    it was the epa or w/e they are called

  8. #8
    RC Enthusiast
    Join Date
    Aug 2013
    Posts
    23
    wd-40 it worked for me

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •