Results 1 to 6 of 6
  1. #1
    RC Qualifier
    Join Date
    Oct 2010
    Location
    NJ
    Posts
    777

    ERBE accelerating on its own

    I've had my ERBE for about 1.5 years and just recently it started accelerating on its own - at first only in reverse, now only in forward.

    When it starts accelerating on its own going forward, the brakes work, but I will eventually lose reverse altogether.

    Turning the transmitter off will stop the car if it accelerates on its own (the car is still turned "on"). Stated another way, the ERBE only accelerates on its own if the transmitter is on.

    I've reprogrammed the ESC, rebound the transmitter/receiver, put fresh batteries in the transmitter, made sure trim is set properly, and I'm running 50/50 on the transmitter.

    Anyone have any ideas on what happening? Could it be just a bad receiver and/or transmitter?

    Thanks!

  2. #2
    RC Turnbuckle Jr. 87 GN's Avatar
    Join Date
    Mar 2010
    Location
    kansas
    Posts
    7,843
    hummm you set the throttle break neutral?? do you have a spare Rx & radio to try?

    Speed Control Programming Instructions

    The Castle Creations Mamba Max speed control should not need
    reprogramming with normal use. However, if you install a different
    radio system in your model, or change the transmitter’s throttle-neutral
    setting from 50/50 to 70/30, you will need to reprogram the speed
    control. Follow these instructions to reprogram the speed control:
    1. Install the batteries of your choice in the battery compartments and
    plug the batteries into the speed control.
    2. Switch on your transmitter.
    3. Hold full throttle while you switch on the Mamba Monster controller.
    After a few seconds, you will hear multiple tones and the
    RED LED will light.
    4. Hold full brake. After a few seconds, you will hear multiple tones
    and the YELLOW LED will light.
    5. Release the trigger to the neutral position. After a few seconds,
    you will hear multiple tones and ALL THE LEDs will light.
    Would you go flip my truck back over??

  3. #3
    RC Qualifier
    Join Date
    Oct 2010
    Location
    NJ
    Posts
    777
    Thanks for the great advice GN!

    I followed the instructions above to reprogram the speed control and it solved my problem.

    On another note: the beeps indicating the ESC is ready took forever to come on. Now the beeps come on quickly. So 2 problems solved.

  4. #4
    RC Qualifier
    Join Date
    Oct 2010
    Location
    NJ
    Posts
    777
    Something is still wrong. It started accelerating on its own again and the "ready" beeps are taking about 20 seconds to sound. I think I just need to try replacing the receiver and/or transmitter. My motor also got very hot - might be because I had to keep the brakes on most of the time.

  5. #5
    RC Turnbuckle Jr. 87 GN's Avatar
    Join Date
    Mar 2010
    Location
    kansas
    Posts
    7,843
    is one or both of the steering servos getting hot.... a bad servo can cause the ESC to do odd things............??
    Would you go flip my truck back over??

  6. #6
    RC Qualifier
    Join Date
    Oct 2010
    Location
    NJ
    Posts
    777
    You know I didn't even check. I'll look for it next time. The reason I keep pointing to a faulty receiver/transmitter is because when it accelerates on its own, I can stop the car by turning the transmitter off. Got new Tx/Rx on the way, so we'll see.

    I forgot to mention, my batteries were also very hot, not just the motor.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •