Results 1 to 14 of 14
  1. #1
    RC Racer
    Join Date
    Apr 2013
    Location
    boise
    Posts
    112

    Flashing red on ESC

    Ok I just bought this revo and tested it out with no problems. We were running lipo. Was running fine and ran it when I got home and it just stopped with flashing red light ***

  2. #2
    RC Qualifier
    Join Date
    Mar 2012
    Location
    Pittsburgh, PA
    Posts
    662
    Sounds like the low voltage protection kicked in if it was a slow flashing red light. Charge battery and try again. FYI if it flashes red fast it's the overheating protection.

  3. #3
    RC Racer
    Join Date
    Apr 2013
    Location
    boise
    Posts
    112
    It's flashing red fast then when I turn my remote off it turns green this is with a charged lipo

  4. #4
    RC Enthusiast
    Join Date
    May 2013
    Location
    Roy, Utah
    Posts
    22
    Fast Flashing red is thermal protection

  5. #5
    RC Enthusiast
    Join Date
    May 2013
    Location
    Roy, Utah
    Posts
    22
    Oops didnt pay attention to second post. sorry

  6. #6
    RC Racer
    Join Date
    Apr 2013
    Location
    boise
    Posts
    112
    This car is so weird so I was able to cycle threw all the settings. The car should now be in sport mode. But to do this I had to turn my remote off and when the remote is off is the only time I get any lights on the ESC then when I turn the remote on the light on the ESC turns off and if you look really well you can see a slight very hard to see fast flashing red light and then I can't do anything from that point???????

  7. #7
    RC Qualifier
    Join Date
    Nov 2011
    Posts
    277
    Old batteries in the radio?

    Open your receiver box also and see what your receiver is telling you.

  8. #8
    RC Racer
    Join Date
    Apr 2013
    Location
    boise
    Posts
    112
    New bats in the radio tryed charged lipo and nickle. What should I look for on the receiver

  9. #9
    RC Qualifier
    Join Date
    Nov 2011
    Posts
    277
    Flashing lights. Only one I remember off the top of my head is red/green flashing means bad servo or trim issues.

  10. #10
    RC Racer
    Join Date
    Apr 2013
    Location
    boise
    Posts
    112
    I'm getting frustrated with this. No clue what's going on fresh baterries all around but still nothing. Ill turn on the ESC after I turn the remote on and all I get is a very small flashing red light going to be contacting traxxas support Monday

  11. #11
    RC Qualifier
    Join Date
    Mar 2012
    Location
    Pittsburgh, PA
    Posts
    662
    Can you take a video of what it's doing and post it up?

  12. #12
    RC Racer
    Join Date
    Apr 2013
    Location
    boise
    Posts
    112
    Um I don't know I can try. I can't even figure out the right way to post pictures

  13. #13
    RC Racer
    Join Date
    Apr 2013
    Location
    boise
    Posts
    112
    Ok so I had some time to tinker with the car today. Opened the receiver box and unplugged the steering servo. I pushed and pulled the throttle and nothing happened but when I turn the steering on the remote the tiers will spin, not fast but will rotate. Any ideas.. Thanks

  14. #14
    RC Qualifier
    Join Date
    Nov 2011
    Posts
    277
    You have the channels reversed.

    Steering servo goes into Ch1 (there are two channel 1 spots, because it can handle dual servos, that is how I remember )

    ESC goes into ch 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •