Results 1 to 10 of 10
  1. #1
    RC Enthusiast
    Join Date
    Nov 2012
    Location
    Muncie IN
    Posts
    40

    Traxxas stampede 4x4 vxl Problem. Squealing HELP!!!!

    Hi guys I have an issue. well i drove my stampede 4x4 yesterday just fine, sounded great and ran great speed of (55 Mph). after i ran it i tightend my slipper clutch a 1/2 a turn to do wheelies and stuff for tomorrow and went to drive it and the motor squeals and has a total loss of speed and power . Please help me IDK what has happened to it.

  2. #2
    RC Turnbuckle Jr. spenniepoos's Avatar
    Join Date
    Apr 2012
    Location
    Wales in the UK
    Posts
    5,025
    Your slipper pads could be cooked or a bearing and have a look at the motor as well dude.....peace
    Famous last words...watch this!!!!

  3. #3
    RC Qualifier
    Join Date
    Nov 2011
    Location
    Austin, Texas
    Posts
    970
    55 with a VXL is not a great idea. Hopefully you have some upgrades. If not, you probably will soon.

  4. #4
    RC Qualifier
    Join Date
    May 2013
    Location
    Erie, PA
    Posts
    591
    Possibly you turned the slipper nut the wrong way. If its too loose it will squeal cuz its slipping too much, therefore that would explain why you have a lose in power. Clockwise to tighten, Counterclockwise to loosen. Take slipper apart, check the pads. If they are shiny, hit them up with a light file or sandpaper. Reassemble then tighten it all the way (without too much force) then loosen the nut 1/4 to 3/8 turn to do some wheelies.

  5. #5
    RC Turnbuckle Jr. spenniepoos's Avatar
    Join Date
    Apr 2012
    Location
    Wales in the UK
    Posts
    5,025
    If it was his slipper it would not have loss speed dude just super acceleration and wheeliesKeep us informed on what happened to your pede bro......peace
    Famous last words...watch this!!!!

  6. #6
    RC Qualifier
    Join Date
    May 2013
    Location
    Erie, PA
    Posts
    591
    Maybe I am just not understanding the problem properly or how the slipper works. I would think that if the slipper clutch was too loose, it would squeal cuz its slipping. If it was loose, then I would think that all the power from the motor would be lost in the slipper clutch due to it slipping. I know I you go like 1/2 turn or more you lose the ability to due wheelies (at least in my experience) Please correct me if I am wrong.

  7. #7
    RC Turnbuckle Jr. spenniepoos's Avatar
    Join Date
    Apr 2012
    Location
    Wales in the UK
    Posts
    5,025
    I can understand were you are coming from but it would not become that loose with out it getting gradually getting worse unless the slipper nut has totally failed and if it was that loose that it would only run at half speed the pads would fall out or the slipper pad disc would come off the pressure disc.......peace
    Famous last words...watch this!!!!

  8. #8
    RC Qualifier
    Join Date
    May 2013
    Location
    Erie, PA
    Posts
    591
    Ok thanks for clearing that up.

  9. #9
    RC Turnbuckle Jr. O.G.'s Avatar
    Join Date
    Nov 2010
    Location
    South of St Louis
    Posts
    5,986
    If the only thing you did is adjust the slipper then that has to be the problem. Tighten all the way then loosen 1/4 turn and go from there.
    My Black & Blue Rally is faster than your color...

  10. #10
    RC Enthusiast
    Join Date
    Nov 2012
    Location
    Muncie IN
    Posts
    40
    Alright thanks to all of I fixed it and I tightened the slipper clutch all the way and loosen it 1/2 a turn and I am now able to do wheelies thanks you all. So nice to have the help

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •