Results 1 to 6 of 6

Thread: T Maxx 3.3

  1. #1
    RC poster
    Join Date
    Dec 2012
    Posts
    1

    T Maxx 3.3

    I started my T Maxx after about three weeks it went to full throttle what would cause this

  2. #2
    RC Qualifier
    Join Date
    Apr 2013
    Posts
    469
    trigger pulled all the way back in transmitter would cause it.

  3. #3
    RC Racer
    Join Date
    Jan 2012
    Posts
    126
    Your vehi0cle could have lost connection with your transmitter and caused it to go to WOT or a linkage could have came loose or broke. Check over the vehicle and see if the radio will control the throttle without the engine running to find your problem area.

  4. #4
    RC poster
    Join Date
    Jul 2013
    Posts
    6
    I just bought a new Slasher about 3 days ago, on first start it went wide open. Pulled off air filter and my carb was set half open from factory. Pulled of the lever and reset to 1mm. Runs great now.

  5. #5
    RC Racer
    Join Date
    Dec 2012
    Location
    SE Lower Michigan
    Posts
    232
    Usually when it goes WOT the batteries are low and the servo goes to WOT.
    Scott

    4909 MAXX 3.3
    4910 MAXX 2.5

  6. #6
    RC Racer
    Join Date
    Dec 2012
    Posts
    103
    if you want to prevent that go with digital servos it really helps (check your pm messages and I will give you links to some of the best for me).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •