Results 1 to 6 of 6

Thread: Tekin RX8

  1. #1
    RC Enthusiast
    Join Date
    Jun 2013
    Posts
    24

    Tekin RX8

    I got my RX8 wet in my Emaxx and had to send it back for repairs, just got it back and installed and the steering all works but no forward or reverse, I put all wires back were they were and hooked it to the Hotwire on the comp. but no luck any ideas?

  2. #2
    RC Turnbuckle Jr.
    Join Date
    Jun 2010
    Location
    Miami, Fl
    Posts
    6,731
    Did you recalibrate the Esc with the radio ?

  3. #3
    RC Enthusiast
    Join Date
    Jun 2013
    Posts
    24
    Quote Originally Posted by RC-Fan View Post
    Did you recalibrate the Esc with the radio ?
    I rebinded the receiver to the transmitter and have steering but no forward or reverse. Not sure how to recalibrate the esc with the radio?

  4. #4
    RC Turnbuckle Jr.
    Join Date
    Jun 2010
    Location
    Miami, Fl
    Posts
    6,731
    that's why you don't have throttle or reverse...
    1. turn the esc off
    2. turn on the radio, pull the throttle, and hold it
    3. turn the esc on,,listen to the beeps, and lights, when the beeps change put reverse on the radio, and hold it.
    4. when it beeps again let the throttle on neutral
    5. the esc should reset itself and be ready to run.

    Try youtube it might be easier to understand, tekin is not easy to set up if you are new to it, hotwire has a lot of the functions, be sure to set up the lipos correctly on the esc because it doesn't have auto lipo, you can't switch lipos from 4s to 6s without doing it first on the esc, if not it won't work. That's why I got rid of it, and keep the MMM much more simple.
    Last edited by RC-Fan; 06-16-2013 at 11:16 AM.

  5. #5
    RC Enthusiast
    Join Date
    Jun 2013
    Posts
    24
    Found instructions for recalibrating and tried it and it won't recalibrate no lights or beeps, on tekins website it says to turn on the radio then esc and hold the mode button down on the esc for three seconds with the radio in neutral and it will beep and then go full throttle then reverse but i got nothing. I am using a futaba remote and tried reversing the motor but still nothing guess I will call tekin in the morning.

  6. #6
    RC Turnbuckle Jr.
    Join Date
    Jun 2010
    Location
    Miami, Fl
    Posts
    6,731
    Make sure the esc is plugged correctly onto the receiver, CH2, -/+ on the correct side, don't reverse the motor.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •