Results 1 to 7 of 7
  1. #1
    RC poster
    Join Date
    Jun 2013
    Posts
    4

    Having trouble with new TQi and old 3.3 REVO

    Hi all

    I just bought a TQi 4 channel radio and am having some trouble getting it to work with my revo. I'm probably just missing something so hopefully you guys can help me out. Its a 6507 model and the old style 3.3 revo if it helps. Anyway when I hook the reciever to the optidrive the only thing that works is the steering, no response from the throttle or the transmission shift. I found the instruction very vague as far as initital installation but I'm most likely missing something obvious. I've seen some posts on bad recievers out of the box......hopefully this is not the case.

  2. #2
    RC poster
    Join Date
    Jun 2013
    Posts
    4
    Anyone? Anyone?

  3. #3
    RC Turnbuckle Jr. JimmyNeutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, Michigan
    Posts
    12,291
    Some opti drives will not work with 2.4 radios... but since Traxxas gave them all the same part number it makes it more difficult to direct you in the correct direction.
    Whatever it is I just typed... could be wrong.

  4. #4
    RC poster
    Join Date
    Jun 2013
    Posts
    4
    Well that sucks lol. I hooked the old remote back up and everything works fine. Now I'm wondering if I should just return the darn thing.

  5. #5
    RC Turnbuckle Jr. JimmyNeutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, Michigan
    Posts
    12,291
    I have tried to remember the specifics, but all I can come up with is that there is something with the label colors that differentiate between what will and will not work with 2.4 radios.

    I know there is at least 1 thread I was apart of in this section of the forum on this very subject... but it is buried. However... if you want to dig it up it probably has the info you are looking for in it.
    Whatever it is I just typed... could be wrong.

  6. #6
    RC poster
    Join Date
    Jun 2013
    Posts
    4
    Ok thanks, I'll do some digging and see what I can find.

  7. #7
    Traxxas Employee TireSlinger's Avatar
    Join Date
    Sep 2010
    Posts
    500
    The word "Set" will be written in red lettering if it is the newer OptiDrive. If it has white "Set" lettering I do not believe it will work with the 2.4 GHz radio system. Just to run a test, plug the throttle servo straight into channel 2 and the shift servo straight into channel 3. If everything works then it is probably either an issue with that version of the OptiDrive or maybe just a bad one altogether.

    The change happened so long ago I doubt you will have issues finding a newer one. Part number 5398.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •