Results 1 to 11 of 11
  1. #1
    RC Qualifier
    Join Date
    Mar 2013
    Location
    Amarillo, tx
    Posts
    417

    Rebuilt 3.3 wont stay started?

    Alright well i just rebuilt my 3.3 with a new piston and sleeve. Long story short when i try to start it, (pullstart) it is really hard to pull on and is hard to get it to turn over (not sure if this is normal because i bought this 3.3 used from a buddy for really cheap and its my first nitro. I got 5 gallons through it and it already had 4 gallons on it when i got it.) And then when i finally get it started it will not stay started, ive tried leaning out the hsn and lsn and also tryed to increase idle. Nothing works
    2400kv rusty ~ 4100kv merv
    Revo .26 X2
    Jato .21

  2. #2
    RC Qualifier
    Join Date
    Oct 2012
    Location
    Puttin out a fire
    Posts
    575
    Loosen the glow plug a little until it starts then re-tighten it. I had to do this with mine awhile back during breakin.
    E-REVO MMM - Stampede 4x4 6s/3s

  3. #3
    RC Qualifier
    Join Date
    Dec 2011
    Location
    Woodward, OK
    Posts
    468
    You may have the piston in backwards. There is a cutout on the skirt of the piston, it should face forwards, towards the carb. Also the hole in the con rod should face forward. You can check, by removing your exhaust header pipe, turn the engine over and look through the exhaust port. If when the piston comes up, you can see the cutout, the piston is installed backwards. Symptoms are hard to start, requires lots of throttle to start, and will not stay running, or idle. The piston will be hard to move when new also, that is pretty normal.
    T-maxx 3.3
    Rusty 2.5r
    Summit VXL
    Nitro 4-tec

  4. #4
    RC Racer
    Join Date
    May 2013
    Location
    Attica,IN
    Posts
    189
    Warm the engine with a hair dryer will also help..assuming the piston is intalled correctly like west said
    T-MAXX 2.5R
    Slayer Pro
    Revo
    Monster Pirate

  5. #5
    RC Qualifier
    Join Date
    Mar 2013
    Location
    Amarillo, tx
    Posts
    417
    I am pretty sure i put the piston in wrong just by remembering, ill check to make sure
    2400kv rusty ~ 4100kv merv
    Revo .26 X2
    Jato .21

  6. #6
    RC Qualifier
    Join Date
    Mar 2013
    Location
    Amarillo, tx
    Posts
    417
    Nope, its in the right way.
    2400kv rusty ~ 4100kv merv
    Revo .26 X2
    Jato .21

  7. #7
    RC Qualifier
    Join Date
    Mar 2013
    Location
    Amarillo, tx
    Posts
    417
    Waiting for my new pullstart to come in
    2400kv rusty ~ 4100kv merv
    Revo .26 X2
    Jato .21

  8. #8
    RC Qualifier
    Join Date
    Jan 2013
    Location
    Gurley, Alabama
    Posts
    766
    How old is your fuel? And has the cap stayed off the fuel bottle for any length of time?

  9. #9
    RC Qualifier
    Join Date
    Mar 2013
    Location
    Amarillo, tx
    Posts
    417
    Its a brand new gallon of sidewinder v2 30% and no, i only take it off to put fuel in my refuel bottle.
    2400kv rusty ~ 4100kv merv
    Revo .26 X2
    Jato .21

  10. #10
    RC Qualifier
    Join Date
    Mar 2013
    Location
    Amarillo, tx
    Posts
    417
    I got it started, on the 2nd tank for the break in
    2400kv rusty ~ 4100kv merv
    Revo .26 X2
    Jato .21

  11. #11
    RC poster
    Join Date
    Feb 2013
    Posts
    8
    Quote Originally Posted by xNitroAddictx View Post
    I got it started, on the 2nd tank for the break in
    what did you do or the problem?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •