Results 1 to 16 of 16
  1. #1
    RC Racer
    Join Date
    Mar 2013
    Location
    up north
    Posts
    100

    Need serious help with my battery not balancing

    The blue balancing connector on my 3s lipo broke off during charging and was just brushing the connector, messing things up. and when i went over to check on it the cells read, 4.1 , the middle kept changing from 4.15-4.3 and the last was 4.2. Is the battery shot or is there something I can do to fix it and will the battery recover to working order. Oh and the connector fell of the battery. Thanks :P


    -spike :P

  2. #2
    Marshal Dadx2mj's Avatar
    Join Date
    Aug 2007
    Location
    So Cal
    Posts
    21,060
    Can you post a picture? Which connector fell of the battery the balance connector or the power connector? This is a Traxxas lipo right?
    BlindMan Racing
    Rusty - MERV - Pede 4x4-Alias
    SPC Lipo Power

  3. #3
    RC Racer
    Join Date
    Mar 2013
    Location
    up north
    Posts
    100
    No I cannot post a picture right now.
    The blue balance connector cord fell off the battery.
    Yes this is a traxxas lipo.


    -spike :P

  4. #4
    RC Racer
    Join Date
    Mar 2013
    Location
    up north
    Posts
    100
    I haven't touched the battery in a week because I don't know what to do. is it going to be destroyed now?


    -spike :P

  5. #5
    RC Racer
    Join Date
    Mar 2013
    Location
    up north
    Posts
    100
    So I soldered the wire back on and charged it and this is what it's been sitting at for at least 20 minutes. Should I cycle it? Is it dead? Please help


    -spike :P

  6. #6
    RC Racer
    Join Date
    Jul 2012
    Location
    Whitecourt, AB
    Posts
    111
    i did what you did cycled mine working fine now

  7. #7
    RC Racer
    Join Date
    Mar 2013
    Location
    up north
    Posts
    100
    Really? I didn't find a cycle on mine :/ but should I just run it and then try and charge it again?


    -spike :P

  8. #8
    RC Racer
    Join Date
    Jul 2012
    Location
    Whitecourt, AB
    Posts
    111
    that should work

  9. #9
    RC Racer
    Join Date
    Mar 2013
    Location
    up north
    Posts
    100
    I've cycled it a few times now( maybe 6 times) and its still only charging to 12.48 volts (4.12 4.20 4.12) and not balancing. Please help


    -spike :P

  10. #10
    Marshal ksb51rl's Avatar
    Join Date
    Nov 2006
    Location
    Northern NJ
    Posts
    15,387
    Sorry, there is no help. Cycling will mot repair a damaged battery. There is no magic or trick to it.
    Alt-248 on the number pad =

  11. #11
    RC Racer
    Join Date
    Mar 2013
    Location
    up north
    Posts
    100
    How damaged is my battery compared to others and what could have damaged it so I know what not to do next time.


    -spike :P

  12. #12
    RC Enthusiast
    Join Date
    May 2012
    Posts
    36
    Are you doing a LiPO balance charge? This is what you need to do to rebalance the battery. For a severely out of balance battery it can take a long time to complete this charge (think on the order of a full day)

  13. #13
    Marshal Dadx2mj's Avatar
    Join Date
    Aug 2007
    Location
    So Cal
    Posts
    21,060
    I'd say it is time to call Traxxas tech support and see about a warranty replacement if they dont have any other ideas on getting it in balance.
    BlindMan Racing
    Rusty - MERV - Pede 4x4-Alias
    SPC Lipo Power

  14. #14
    Marshal ksb51rl's Avatar
    Join Date
    Nov 2006
    Location
    Northern NJ
    Posts
    15,387
    If your pack will not balance during your charge cycle:
    Your cells are seriously mismatched; or
    One or more cells are damaged; or
    You have a very slow balancer; or
    You have a very cheap & inaccurate balancer.

    A healthy pack should never take a day to balance.
    Alt-248 on the number pad =

  15. #15
    RC Racer
    Join Date
    Mar 2013
    Location
    up north
    Posts
    100
    I'm using the traxxas ez peak plus. I've already cut open the shrink wrap in order to repair a broken balance wire so I don't think warranty will cover it but I've also thought of completely talking the pack apart and charging each cell to 3.7 then putting it back together.

    Oh and I'm also using balance mode as always.


    -spike :P

  16. #16
    Marshal ksb51rl's Avatar
    Join Date
    Nov 2006
    Location
    Northern NJ
    Posts
    15,387
    Don't keep playing with it. It is bound to bite you.
    Alt-248 on the number pad =

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •