Results 1 to 9 of 9
  1. #1
    RC Qualifier
    Join Date
    Aug 2012
    Posts
    298

    LvD was off...woops

    I ran my truck a little today...(red light was on) with the LvD off. Had my 2s lipo on the truck...I started slowing down a little so I stopped it...then I noticed LvD was off...Not sure how it got turned off...Guess I should check....I hooked the battery up to my EZ peak plus and it was reading 3.3 volts per cell....Am I ok here?

  2. #2
    RC Qualifier
    Join Date
    Apr 2013
    Posts
    360
    i think your ok. If my memory is right i think it can go down to 3.2 v per cell

  3. #3
    RC Racer
    Join Date
    May 2012
    Location
    Atlanta, GA
    Posts
    119
    I would get a lipo balancer tool to read all 3 voltages for 2 cells. Just to make sure.

  4. #4
    RC Qualifier
    Join Date
    Aug 2012
    Posts
    298
    Not sure how or why it was off...It was on last time I ran the truck...How will I know if I toasted my battery?

  5. #5
    RC Turnbuckle Jr. Wolfslash16's Avatar
    Join Date
    Mar 2012
    Location
    Riverton Utah
    Posts
    4,123
    Not sure how or why it was off...It was on last time I ran the truck...How will I know if I toasted my battery?
    When the smoke detector goes off... JK, just check for some puffing or bulges in the pack, and when it's done charging, see if the cells balanced out.
    Sl2sh Slayer Summit Sl4sh 1/18 Rally/Teton T-Maxx

  6. #6
    RC Turnbuckle Jr. Jimmie Neutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, MI
    Posts
    11,966
    3v/cell is the safe minimum... at 3.3 you were close but probably fine as long as the ESC did not voltage dip too far below the 3v/cell threshold. Just monitor your pack during its next charge... which should be very soon so the pack does not self discharge too low to be safely used.
    Whatever it is I just said... I could be wrong.

  7. #7
    RC Qualifier
    Join Date
    Aug 2012
    Posts
    298
    I am storage charging it now...Taking over an hour to reach storage voltage...But they are balancing ok...Guess it's a lesson learned...Check to see if it's in LvD before u run...

  8. #8
    RC Qualifier
    Join Date
    Apr 2013
    Posts
    360
    Also the button on the vxl esc gets stuck easily. Causing it to turn the esc on/off or putting it in training mode or in ur case most likely turned off lvc. wd40 in the button and press it until it loosens up.

  9. #9
    RC Turnbuckle Jr. spenniepoos's Avatar
    Join Date
    Apr 2012
    Location
    Wales in the UK
    Posts
    4,432
    You are lucky dude that could have been a bummer for your pocket.....peace
    Famous last words...watch this!!!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •