Results 1 to 3 of 3

Thread: TQI Dead......

  1. #1
    RC Champion
    Join Date
    Dec 2010
    Location
    Wisconsin
    Posts
    1,662

    TQI Dead......

    Was out bashing last weekend and in the middle of a run my tqi flat out died. Went back in and charged the rx pack in it, still nothing. Its certainly dead now, wont power on or anything. I thought I read about this happening a while ago, just seeing if anyone else has had this happen.

    Not very happy. Its a the three channel with docking base so it wasnt cheap. Had no physical damage at all. Was never dropped or knocked over even. Its only seen 35 runs but I have had it for a while so traxxas likely wont replace it. We shouldnt have to worry about transmitters randomly dying....
    Land of the free?

  2. #2
    RC Turnbuckle Jr. Wolfslash16's Avatar
    Join Date
    Mar 2012
    Location
    Riverton Utah
    Posts
    4,114
    I'd still call Traxxas, just don't mention how long you've had it. They should do something about it, because the TQI should never die like that...
    Sl2sh Slayer Summit Sl4sh 1/18 Rally/Teton T-Maxx

  3. #3
    RC Champion
    Join Date
    Dec 2010
    Location
    Wisconsin
    Posts
    1,662
    I did contact them today. A guy set up an rma for me to send it in but he got my name wrong and I couldnt remember how long Ive had this thing off hand so I told him february when I think I actually got it in december.

    Ill have to redo it now.

    He also said that they MIGHT replace it for free. He did not confirm.
    Land of the free?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •