Results 1 to 5 of 5
  1. #1
    RC Enthusiast
    Join Date
    Apr 2013
    Posts
    35

    problems with my e revo

    so, i was out running my 1/16 brushed e revo today, running wide open, hittin jumps, flippin it, etc and it started to kinda like skip if i pull the throttle all the way at a stop, it wouldnt take off as quick as usual, any ideas on what this problem could be, hopefully an easy fix, just got it back up and running after have many servo problems finally installed a hitec micro servo, way better.

  2. #2
    RC Qualifier
    Join Date
    Mar 2013
    Posts
    363
    i don't own a 1/16 erevo just 1/10's and too me it sounds like your slipper clutch is to loose.on the big brother i tighten all the way then back off a 1/4 turn and never have a problem

  3. #3
    RC Enthusiast
    Join Date
    Apr 2013
    Posts
    35
    ill try that out and see how it works, but it seems to only do it as the battery starts to die. thanks

  4. #4
    RC Qualifier
    Join Date
    Oct 2008
    Location
    Soldotna, Alaska
    Posts
    730
    Quote Originally Posted by Brenthughes View Post
    ill try that out and see how it works, but it seems to only do it as the battery starts to die. thanks
    If that's the case, it's probably just the batteries dieing. Time to recharge. A loose clutch wouldn't case "skipping". It would create a high pitched squealing noise. Or possibly missing some teeth on a gear somewhere, causing it to slip as it comes to that spot on the gear when accelerating, but once up to speed it would be less noticeable.
    Using while stupid may cause serious injury.

  5. #5
    RC Qualifier
    Join Date
    Apr 2013
    Posts
    360
    is your esc going into thermal?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •