Results 1 to 11 of 11
  1. #1
    RC Enthusiast
    Join Date
    Apr 2013
    Location
    Ohio
    Posts
    28

    Traxxas EZ Peak Plus Fan noise.

    I just bought a handful of 2s lipos, and The charger has been great until around the 5th charge. The fan now will spin fast and slow, making a heck of a racket, but then speeds up normally and don't sound like crap.

    I could take the fan out and re lube the bushings, but I would imagine it would void my warranty just like anything else. I took the charger back to the hobby store, and they didn't have anything else or another Traxxas unit. I don't want to spend the time to ship this back to Traxxas, As I don't want to wait for weeks before I get back or replaced.

    My question is, what size fan and what plug does the fan use if any. I have a lot of PC parts, but what to know what the specs of the fan is before I void my warranty for nothing. thanks.
    Last edited by Dadx2mj; 04-28-2013 at 04:11 PM. Reason: Language

  2. #2
    RC Racer
    Join Date
    Nov 2012
    Posts
    202
    if it is still under warranty I would contact traxxas they will most likely replace it. If you try to fix it you could damage it even worse and that would not be replaced.

  3. #3
    RC Turnbuckle Jr. Wolfslash16's Avatar
    Join Date
    Mar 2012
    Location
    Riverton Utah
    Posts
    4,116
    Funny, mine makes I grinding sound at start up too, but it goes away once the fan speeds up. Let us know what Traxxas says if you call them.
    Sl2sh Slayer Summit Sl4sh 1/18 Rally/Teton T-Maxx

  4. #4
    RC Enthusiast
    Join Date
    Apr 2013
    Location
    Ohio
    Posts
    28
    Quote Originally Posted by Wolfslash16 View Post
    Funny, mine makes I grinding sound at start up too, but it goes away once the fan speeds up. Let us know what Traxxas says if you call them.
    Well, I might just wait, I have still 27 days until I can't return the charger to the hobby store, if not, I might crack it open and take a look at it, Its just a fan, shouldn't be anything overly complicated to replace, I use to build PC for a living, so this shouldn't be that bad. But I know I will void my warranty. Plus I have may fans, just hard to see it threw the grill.

  5. #5
    RC Competitor
    Join Date
    Oct 2012
    Location
    Manchester
    Posts
    80
    mine did the same and i just plug it in better cause of bad connection

  6. #6
    RC Champion
    Join Date
    Mar 2011
    Location
    Zeeland Michigan
    Posts
    1,149
    Quote Originally Posted by Viking2121 View Post
    Well, I might just wait, I have still 27 days until I can't return the charger to the hobby store, if not, I might crack it open and take a look at it, Its just a fan, shouldn't be anything overly complicated to replace, I use to build PC for a living, so this shouldn't be that bad. But I know I will void my warranty. Plus I have may fans, just hard to see it threw the grill.
    Y would you wait if it's bad , I would just return it and get a new one , the your warranty starts over . I think this is a no brainier . But it your's do want you want . jmo
    1 Rusty VXL

  7. #7
    RC Enthusiast
    Join Date
    Apr 2013
    Location
    Ohio
    Posts
    28
    Quote Originally Posted by rhardy60 View Post
    Y would you wait if it's bad , I would just return it and get a new one , the your warranty starts over . I think this is a no brainier . But it your's do want you want . jmo
    Im not waiting 2+ weeks to get the charger back, And the hobby store it currently out of stock on these, So Im gonna wait till they restock, if they don't I ripping the thing apart, Sad I have to pay 80 buck then get a defective product, then wait ages to get a replacement, It be different if I had another charger around.

  8. #8
    RC Enthusiast
    Join Date
    Apr 2013
    Location
    Ohio
    Posts
    28
    I have taken it apart, and used some PB-Blaster in the fan shaft. This runs so quiet and at full speed as soon as I hold the start charge button.

    PB-Blaster is like WD-40, so it may need a good lube again a month or so down the road.

    Also Does anyone with this charger leave it plugged in all the time?

  9. #9
    RC Qualifier
    Join Date
    Aug 2012
    Posts
    298
    Quote Originally Posted by Viking2121 View Post
    I have taken it apart, and used some PB-Blaster in the fan shaft. This runs so quiet and at full speed as soon as I hold the start charge button.

    PB-Blaster is like WD-40, so it may need a good lube again a month or so down the road.

    Also Does anyone with this charger leave it plugged in all the time?
    I unplug mine when not in use..



    I had the same noise issue...I called Traxxas support and the tech said the fan was off center and an easy fix....He got it covered under warranty even though I have had it for 3 months... I mailed it away yesterday which works out because my Pede 4x4 is down with a broken front Stub...(teknos fronts on the way)...Hopefully it will come back fast with no more noise issues
    Last edited by Traxxasnoob2012; 05-23-2013 at 10:13 AM.

  10. #10
    RC Enthusiast
    Join Date
    Mar 2013
    Location
    salem,OR
    Posts
    20
    +1 on lubeing the fan. About 2 months after I bought mine It started making terrible noises. Only during start up of the charge cycle. One or two drops of oil on the fan shaft and it runs smoother and more quite then when It was new!

  11. #11
    RC Turnbuckle Jr. Jimmie Neutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, MI
    Posts
    11,957
    Blaster and 40 are not lubricants!!
    Whatever it is I just said... I could be wrong.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •