Results 1 to 2 of 2

Thread: Reverse servo

  1. #1
    RC Competitor
    Join Date
    Apr 2012
    Location
    Red Deer AB
    Posts
    61

    Reverse servo

    Ok. Brand new revo. Never been started, I was installing upgraded steering rods tonight and while I was aligning the tires I flipped it into reverse....and nothing, when I flip the red button into drive the reverse servo hums steady but does nothing. Flip it into reverse and the servo goes quiet.

    The servo is warm to the touch. I have removed the arm and the tranny shifts manually fine. Servo does nothing while detached

    Thoughts anyone. When I got it in dec everything functioned fine. It's been sitting since.

    Thanks for any input.

    http://i245.photobucket.com/albums/g...ps0d3340cd.mp4
    Last edited by stroker3.3; 04-17-2013 at 11:17 PM.

  2. #2
    RC Racer
    Join Date
    Jun 2011
    Location
    uk and texas
    Posts
    175
    chect ur connection to the traxxas link for that servo is in chanel 3 i think thats shift if its buzzing theres power going to the servo so id assume its secured just fine open the servo and i bet uve stripped or have a snapped gear in there its simple just undo the 4 really small screw on the underside of the servo carfully they are fragile and i seem to snap them really easy so dont over tighten them when re installing them put a pic of the gears when u open it if u decide to check them

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •