Results 1 to 6 of 6
  1. #1
    RC Racer
    Join Date
    Feb 2013
    Location
    Buffalo, New York
    Posts
    108

    3.3 goes by itself

    After my 3.3 heats up a bit the car will go by itself after letting go of the break, what do i need to adjust?

  2. #2
    RC Racer
    Join Date
    Mar 2013
    Location
    Rio Rancho new mexico
    Posts
    175
    Quote Originally Posted by slash4x4baja View Post
    After my 3.3 heats up a bit the car will go by itself after letting go of the break, what do i need to adjust?
    idle speed screw its on the carb not the one with the fuel line
    2001 tmaxx, 2012 1/16 erevo vxl

  3. #3
    RC Champion
    Join Date
    Dec 2010
    Location
    Wisconsin
    Posts
    1,662
    Also, the clutch could need adjustment if it that doesnt work.
    Land of the free?

  4. #4
    RC Turnbuckle Jr. Wildman4910's Avatar
    Join Date
    Jun 2009
    Location
    Cocoa Florida
    Posts
    3,808
    Quote Originally Posted by nathan8856 View Post
    idle speed screw its on the carb not the one with the fuel line
    There is no "idle speed screw", there is the HSN, LSN, and the Idle gap screw.
    High idle is a sign of lean LSN, do not mes with the Idle gap screw trying to bring the idle down.
    Idle gap needs to be set at 0.9~1mm & then leave it alone.

    If it's idling too high richen the LSN.

    If it's not idling too high check the clutch spring for breakage/stretching.
    Look out for the tree/crunch!

    LiPo? Naw NITRO!!

  5. #5
    RC Competitor
    Join Date
    Apr 2013
    Location
    Portugal
    Posts
    80
    Quote Originally Posted by slash4x4baja View Post
    After my 3.3 heats up a bit the car will go by itself after letting go of the break, what do i need to adjust?
    Sometimes this also happens to me and I turn LSN (low speed needle)counterclockwise only a little

  6. #6
    RC poster
    Join Date
    Mar 2013
    Location
    Sweden
    Posts
    14
    Quote Originally Posted by slash4x4baja View Post
    After my 3.3 heats up a bit the car will go by itself after letting go of the break, what do i need to adjust?
    Just had this problem today with my revo 3.3.
    Checked my clutch spring, and it was broken.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •