Results 1 to 7 of 7
  1. #1
    RC Competitor
    Join Date
    Apr 2013
    Location
    Portugal
    Posts
    85

    I need help...motor problem

    I do not understand it
    Today I was walking in my revo...when I stopped to refill I could not put it to work again. I tried new plugs, new fuel and the problem continues.
    Have the engine lost is compression?
    Please help
    Last edited by Cyborg; 04-13-2013 at 04:25 PM.

  2. #2
    RC Turnbuckle Jr. Wildman4910's Avatar
    Join Date
    Jun 2009
    Location
    Cocoa Florida
    Posts
    3,999
    Did you try re-priming the fuel lines?
    Look out for the tree/crunch!

    LiPo? Naw NITRO!!

  3. #3
    RC Competitor
    Join Date
    Apr 2013
    Location
    Portugal
    Posts
    85
    I tried today and already works,I saw that the oring fuel tank is not sealing well...maybe it is the oring.
    I do not understand too much about nitro engines,is my first RC nitro

    Thanks

  4. #4
    RC Turnbuckle Jr. Wolfslash16's Avatar
    Join Date
    Mar 2012
    Location
    Riverton Utah
    Posts
    4,373
    What glow plug are you using?

    1,800 POST!
    Sl2sh Slayer Summit Sl4sh Teton/Rally T-Maxx Pnde

  5. #5
    RC Turnbuckle Jr. Wildman4910's Avatar
    Join Date
    Jun 2009
    Location
    Cocoa Florida
    Posts
    3,999
    Quote Originally Posted by Cyborg View Post
    I tried today and already works,I saw that the oring fuel tank is not sealing well...maybe it is the oring.
    I do not understand too much about nitro engines,is my first RC nitro

    Thanks
    If your tanks O~ring is not sealing well that is a major issue, Get some new o~rings #5362 for the tank lid & see if that helps.
    http://buy.traxxas.com/advanced_sear...p?partnum=5362

    If the tank lid o~ring is not sealing then you will not get the fuel pushed up to the carb like it's supposed to.
    Look out for the tree/crunch!

    LiPo? Naw NITRO!!

  6. #6
    RC Competitor
    Join Date
    Apr 2013
    Location
    Portugal
    Posts
    85
    Quote Originally Posted by Wolfslash16 View Post
    What glow plug are you using?

    1,800 POST!
    Is not the glow plug,I use traxxas and OS (hot) glow plugs...both work

  7. #7
    RC Competitor
    Join Date
    Apr 2013
    Location
    Portugal
    Posts
    85
    Quote Originally Posted by Wildman4910 View Post
    If your tanks O~ring is not sealing well that is a major issue, Get some new o~rings #5362 for the tank lid & see if that helps.
    http://buy.traxxas.com/advanced_sear...p?partnum=5362

    If the tank lid o~ring is not sealing then you will not get the fuel pushed up to the carb like it's supposed to.
    already bought it,but it will take about a week to get here
    thanks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •