Results 1 to 6 of 6
  1. #1
    RC poster
    Join Date
    Apr 2013
    Posts
    10

    Slayer Wont Start

    Im new to nitro cars so it might be an easy fix. Ive had my slayer for about a month and have ran 3/4 of a gallon of fuel through it. My slipper clutch recently needed replacement so i got it replaced at my local hobby shop. That day i went home to start the car and after several failed attempts it finally started. However the car wouldnt idle. I ran the car for about 5 minutes when it just shut off. Now everytime i try to start the car all four wheels move and the engine wont fire up. Does anybody know what the problem is.

  2. #2
    RC Turnbuckle Jr. Wolfslash16's Avatar
    Join Date
    Mar 2012
    Location
    Riverton Utah
    Posts
    4,352
    Welcome to the forums! Sounds like your clutch spring broke, I'd check that. Hope this helps!
    Sl2sh Slayer Summit Sl4sh Teton/Rally T-Maxx Pnde

  3. #3
    RC poster
    Join Date
    Apr 2013
    Posts
    10
    Thanks for the quick reply. Noob question but where is that spring located

  4. #4
    RC Turnbuckle Jr. Wolfslash16's Avatar
    Join Date
    Mar 2012
    Location
    Riverton Utah
    Posts
    4,352
    It's inside the clutch bell. The clutch bell is the metal thing coming out of the engine, conecting to the spur gear.
    Sl2sh Slayer Summit Sl4sh Teton/Rally T-Maxx Pnde

  5. #5
    RC poster
    Join Date
    Apr 2013
    Posts
    10
    thanks a lot for the help

  6. #6
    RC Competitor
    Join Date
    Aug 2011
    Location
    Newfoundland, Canada
    Posts
    87
    Just replaced the clutch spring on my revo an hour ago. Classic symptoms....good idea to have a couple clutch shoes and springs on hand cuz it will break again!

    Sent from my Nexus 7 using Tapatalk 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •