Results 1 to 4 of 4
  1. #1
    RC Enthusiast
    Join Date
    Nov 2012
    Posts
    37

    one way bearing issues

    Hey guys i have 4 of the Slayer pro 4x4 and i have had nothing but trouble with the one way bearings on them not working correctly. Is this a common issue? I have already go through 3 of them and they arnt cheap I have tried cleaning them and everything. I also put new starter shafts in each time. What makes it start to slip so much so fast? I only had maybe if im like 3 hours of running on the last one before it gave away. I just dont get it and hope for some help if you all would be willing.

    -Rick-

  2. #2
    RC Enthusiast
    Join Date
    Jan 2013
    Location
    Sweden
    Posts
    37
    I'm about done with the one way bearings. 1 year, 2 engines, and 4 bearings. Usually it slips but sometimes it gets stuck. Maybe I'm doing something wrong?

    I'd like to see a new future without owb's. Kyosho has a nice alternative but it won't fit the 3.3 or the Picco.
    http://youtube.com/adolfss0n

  3. #3
    RC Turnbuckle Jr. fallonguy's Avatar
    Join Date
    May 2006
    Location
    Dayton Nv.
    Posts
    3,181
    You can get a starter box and then don't need the OWB.



    http://www.rcboca.com/rd-logics-star...FeN_Qgod50gAqA
    I wanted to put a really cool signature but I ran

  4. #4
    RC Enthusiast
    Join Date
    Jan 2013
    Location
    Sweden
    Posts
    37
    Carry that starter box around and going back to charging batteries, not my cup of tea (that's why I ditched the EZ starter). I like the simplicity of a pull start. Too bad it fails at the owb.
    Scroll down to see what can be done: http://www.offroad-cult.org/Tracktes..._2_english.htm

    But what's the correct maintence for the owb to reach a long life?
    http://youtube.com/adolfss0n

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •