Results 1 to 5 of 5
  1. #1
    RC Competitor
    Join Date
    Jan 2013
    Location
    Perth Australia
    Posts
    74

    optional 17 tooth pinion

    hi i just installed the 17 tooth pinion for a bit of fun out the front on the road. now i got mega fan installed and esc fan but after about 15 mins of straight hi speed runs with trenchers balloning like crazy. i pulled up to a weird smell i touched motor cool as a cucumber same as esc fins. but my battery was pretty warm and pretty sure that was where the smell was coming from here is a photo of battery only 2s 30c 5200mah can some one please explain if you know what might of made it happen and after 10 mins unpluged smell went away and battery good now.

    but that pinion opens it up some thing stupid



    [IMG][/IMG]


    [IMG][/IMG]

  2. #2
    RC Turnbuckle Jr. spenniepoos's Avatar
    Join Date
    Apr 2012
    Location
    Wales in the UK
    Posts
    5,636
    Make sure it not the slipper pads as well dude and if it is your battery dont push it because it could melt all your vxl system or lipo smoking time......peace
    Famous last words...watch this!!!!

  3. #3
    RC Competitor
    Join Date
    Jan 2013
    Location
    Perth Australia
    Posts
    74
    Quote Originally Posted by spenniepoos View Post
    Make sure it not the slipper pads as well dude and if it is your battery dont push it because it could melt all your vxl system or lipo smoking time......peace
    slipper pads look good just while i was thinking and going over car missed some thing out. It was shuttering very bad after it cane to a stop and i was about to take of again never happened with 11 tooth

  4. #4
    RC Turnbuckle Jr. spenniepoos's Avatar
    Join Date
    Apr 2012
    Location
    Wales in the UK
    Posts
    5,636
    If they get a glaze on them will slip more and smell and check temps of your battery and just make sure its not coming from the esc or motor dude ......peace
    Famous last words...watch this!!!!

  5. #5
    RC Qualifier
    Join Date
    Nov 2011
    Location
    Portland OR
    Posts
    381
    My guess is that your asking the battery to do way to much and its overheating. The motor and esc was meant to run on 3s with the 17t and you may get them hot if pushed to hard.

    Another way to put it. Gear up a 2s lipo if its 50c plus. Or get a decent 30c 3s lipo to go fast.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •