Results 1 to 10 of 10
  1. #1
    RC Racer
    Join Date
    Feb 2013
    Location
    Buffalo, New York
    Posts
    112

    Question E-Revo wheel wobble

    I just got a set of pro-line trenchers for my e revo and one of the wheels wobbles pretty bad no matter what axle the wheel is on. Is there any way to fix this? Its not slop from the hex's because all the other wheels are fine. I made a short clip to show the issue.


  2. #2
    RC Qualifier
    Join Date
    Jan 2013
    Location
    The Netherlands
    Posts
    851
    Looks like a bad glue job i'm afraid .

  3. #3
    RC Turnbuckle Jr.
    Join Date
    Mar 2012
    Location
    so cal
    Posts
    9,244

  4. #4
    RC Racer
    Join Date
    Feb 2013
    Location
    Buffalo, New York
    Posts
    112
    thanks for the link, They came pre mounted though so ill have to see if maybe they will exchange it first before un gluing it

  5. #5
    RC Qualifier
    Join Date
    Jan 2013
    Location
    The Netherlands
    Posts
    851
    Does it damage your rim and tires that you know of? I have some spots that could have been better, but its not really necessary, but i could try to debond them..

  6. #6
    RC Turnbuckle Jr. MITCH316's Avatar
    Join Date
    May 2012
    Location
    Australia
    Posts
    3,255
    It may be a bad glue job...look at the rim while throttling to see if the rim is wobbling. If the rim is not wobbling then you know its a bad glue job.
    Rock n Rolla !

  7. #7
    RC Turnbuckle Jr. 87 GN's Avatar
    Join Date
    Mar 2010
    Location
    kansas
    Posts
    7,837
    Traxxas 17mm hubs?? hummm looks like it is not sitting flat on the hub..maybe??not??

    Might just need to be ran, & see if it will true up. Like a flat spot??

    You said it does the same thing on other hubs, fronts & left rear.
    Would you go flip my truck back over??

  8. #8
    RC Racer
    Join Date
    Feb 2013
    Location
    Buffalo, New York
    Posts
    112
    Its definitely the tire and not the wheel, im going to give it a few high speed passes when the weather gets better and hopefully that will be enough to true it up, if not ill have to remount it.

  9. #9
    RC Qualifier
    Join Date
    Jun 2012
    Location
    Norway
    Posts
    290
    I've run my ERBE for the first time yesterday, also with Trencher X's and I've also noticed that they wobble quite horribly. And mind you, I have HPP hubs installed.

  10. #10
    RC Qualifier
    Join Date
    Jan 2013
    Location
    The Netherlands
    Posts
    851
    Mine a little, but it was my first time gluing a tire, so i guess thats why. Also have HPP hubs and the rims don't seem to wobble at all.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •