Results 1 to 4 of 4
  1. #1
    RC poster
    Join Date
    Mar 2013
    Location
    Alabama
    Posts
    5

    Question Rally VXL esc shutting off

    If my Rally has a good traction roll or something of that nature, the ESC shuts off and will only reboot after disconnecting/reconnecting battery pack. Whats the deal??

  2. #2
    RC Champion
    Join Date
    Jan 2012
    Location
    Colorado Springs, CO.
    Posts
    2,039
    is it a new car? do you have any bare wires anywhere? have you tried another battery? are you running Lipo or nimh batteries? do you hvae the ESC set to the correct setting. have you had issues with the servo?

  3. #3
    RC poster
    Join Date
    Mar 2013
    Location
    Alabama
    Posts
    5
    It is new. I've only run 4-5 packs through it. Lipo 2s(20c and 25c). ESC set for low voltage shut(lipo setting). Its done it from day one. No servo issues. Bare wires...no. I will certainly recheck connections though. I've only run venom batteries thus far. I have a couple traxxas 25c 2s and I don't believe Ive tried them yet. So I can def try the different packs. Just wondering if there was some common issues like this on other vehicles. I have a older slash ultimate VXL that has been driven HARD and has same ESC and it never cuts off.

    Thanks for the reply.

  4. #4
    RC Champion
    Join Date
    Mar 2011
    Location
    The Mitten
    Posts
    1,676
    Call Traxxas Support. They will troubleshoot with you to try and find what is the culprit. And being this new should be in warranty still also.
    Everything overpowered...

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •