Results 1 to 13 of 13
  1. #1
    RC poster
    Join Date
    Mar 2013
    Location
    Florence, KY
    Posts
    18

    New XO-1 owner......with questions

    hey there everyone. name is Dave and am a proud owner of an XO-1 for a couple weeks now . i'm a newbie to this type of RC, but have driven several rc's in the past, just nothing to this advanced. and even though it says "expert drivers", it was an awesome $ deal that i couldn't pass up.

    anyways, been trolling the forum for a couple weeks searching and getting some knowledge about the XO. lots of useful info from some very experienced people i see. but i did have a couple questions that i was curious about that i can't really find.

    one is, i've driven the car a few times in the past couple weeks (stock gears out of the box till i do a couple mods). i noticed on the transmitter dashboard, the voltage starts off at 25v and when it gets down to 19v, the car dies. is this the normal cut off for this? if so, what is the reason why? seems 19v is still quite a bit of stored energy to drive on. but i'm most likely wrong (remember <-----newb lol)

    second one is, noticed a couple empty ports on the tQi, what are some things everyone is adding to them to "personalize" their XO?

    big thanks ahead of time to everyone :-)

  2. #2
    RC Champion
    Join Date
    Feb 2011
    Location
    Lexington, SC
    Posts
    2,158
    19 total volts is 3.167 volts per cell. Most likely the low voltage cutoff is set to 3.2v per cell. So, this seems normal to me. You can add extra cooling fans, lights, etc. to the extra ports on the receiver.
    Jeremy

  3. #3
    RC poster
    Join Date
    Mar 2013
    Location
    Florence, KY
    Posts
    18
    shew, ok cool. am glad that is normal.

    so as far as the extra fans and lights and such go, i am going to assume once they are plugged in and the unit is switched on, they will just come on automatically and aren't really programmable options? say, installing red led brake lights and having them light up with the brakes are engaged?

  4. #4
    RC Racer
    Join Date
    Dec 2012
    Posts
    196
    I dont own a xo1 i own a slash but you can go to ebay and buy from there heres the link. http://item.mobileweb.ebay.com/viewi...d=180975698414
    It may add more weight

  5. #5
    RC Champion
    Join Date
    Feb 2011
    Location
    Lexington, SC
    Posts
    2,158
    Yeah, you definitely need a controller to get the lights to do different things, otherwise they will just stay lit when powered from the receiver.
    Jeremy

  6. #6
    RC poster
    Join Date
    Mar 2013
    Location
    Florence, KY
    Posts
    18
    Quote Originally Posted by razorback fan View Post
    I dont own a xo1 i own a slash but you can go to ebay and buy from there heres the link. http://item.mobileweb.ebay.com/viewi...d=180975698414
    It may add more weight
    ha, that's pretty slick. thanks for that link razorback, gonna have to purchase that. may replace a couple of the LED's with different colors, like the blue stop lights with red ones lol. but thanks again

    Quote Originally Posted by ponie1992 View Post
    Yeah, you definitely need a controller to get the lights to do different things, otherwise they will just stay lit when powered from the receiver.
    cool, thanks ponie.

  7. #7
    RC Racer
    Join Date
    Apr 2011
    Posts
    223
    Quote Originally Posted by razorback fan View Post
    I dont own a xo1 i own a slash but you can go to ebay and buy from there heres the link. http://item.mobileweb.ebay.com/viewi...d=180975698414
    It may add more weight
    This is awesome for real.
    2K11 Nitro Monster Truck Champ Tmaxx 3.3

  8. #8
    RC Champion
    Join Date
    Feb 2011
    Location
    Lexington, SC
    Posts
    2,158
    Quote Originally Posted by civicninja98 View Post
    cool, thanks ponie.
    No problem. Post up some pics when you get it all hooked up.
    Jeremy

  9. #9
    RC poster
    Join Date
    Mar 2013
    Location
    Florence, KY
    Posts
    18
    Quote Originally Posted by ponie1992 View Post
    No problem. Post up some pics when you get it all hooked up.
    will do :-)

  10. #10
    RC Racer
    Join Date
    Dec 2012
    Posts
    196
    Quote Originally Posted by civicninja98 View Post
    will do :-)
    Glad i could help you good luck with the xo1

  11. #11
    RC poster
    Join Date
    Mar 2013
    Location
    Florence, KY
    Posts
    18
    so, I bought the light kit that razorback showed a link to. very cool kit. did a dry run on it to make sure everything worked ok. everything worked fine. went through and ran the the wires through with the other wires making it "neat" did another hookup before I drilled holes in the body to make sure everything still worked......and nope. some lights flashed when they shouldn't, others didn't flash when the should and some didn't come on at all. so, luckily I didn't have holes in the bod before I tried the lights again. did get a refund from the seller which was good and didn't want the item back because it came from china and the shipping would have been ridiculous. so now I just have some extra LED's.

    just wanted to let you all know about the kit. idk if it was a fluke thing or if something is over juicing the controller in the kit. but it worked once lol.

  12. #12
    RC Racer
    Join Date
    Dec 2012
    Posts
    196
    Quote Originally Posted by civicninja98 View Post
    so, I bought the light kit that razorback showed a link to. very cool kit. did a dry run on it to make sure everything worked ok. everything worked fine. went through and ran the the wires through with the other wires making it "neat" did another hookup before I drilled holes in the body to make sure everything still worked......and nope. some lights flashed when they shouldn't, others didn't flash when the should and some didn't come on at all. so, luckily I didn't have holes in the bod before I tried the lights again. did get a refund from the seller which was good and didn't want the item back because it came from china and the shipping would have been ridiculous. so now I just have some extra LED's.

    just wanted to let you all know about the kit. idk if it was a fluke thing or if something is over juicing the controller in the kit. but it worked once lol.
    Sorry, that really sucks

  13. #13
    RC poster
    Join Date
    Mar 2013
    Location
    Florence, KY
    Posts
    18
    Quote Originally Posted by razorback fan View Post
    Sorry, that really sucks
    no big deal. may try to fix it actually. will give me something to do while i'm off work lol.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •