Results 1 to 6 of 6
  1. #1
    RC Qualifier
    Join Date
    May 2011
    Posts
    374

    Not taking full charge????????

    Hey i have the "hitec x4 ac plus" charger and im trying to charge my batteries, they are 4600 mAh so i set the charger at 2 amps auto, capacity cut-off is 4600 and the peak sensitivity is at default. but when they are done they only take around 3700 mAh i don't know why, they are fairly new are they just false peaking or am i charging them wrong?


    Any help is appreciated
    The smartest person, asks the most questions...

  2. #2
    RC Champion
    Join Date
    Nov 2012
    Posts
    1,171
    It will take a few charges to get up to full. Don't worry to much about it. I have 6 5000mah that only charge to 3600 or so but I still get a 1/2 hour or more run time out of them

  3. #3
    RC Qualifier
    Join Date
    May 2011
    Posts
    374
    okay so im guessing its normal, is it also normal for the batteries to die fairly quick on the first couple runs cause they seem to go maybe ten minutes then they die? and what is a good peak setting for nimh batteries
    The smartest person, asks the most questions...

  4. #4
    RC Champion
    Join Date
    Mar 2011
    Location
    Zeeland Michigan
    Posts
    1,196
    Try recycling the battery's and a slow charge at 1 amp . Sometimes that well bring them back to life .
    1 Rusty VXL

  5. #5
    RC Champion
    Join Date
    Nov 2012
    Posts
    1,171
    Quote Originally Posted by Dann117elite View Post
    okay so im guessing its normal, is it also normal for the batteries to die fairly quick on the first couple runs cause they seem to go maybe ten minutes then they die? and what is a good peak setting for nimh batteries
    It can take up to 10 cycles of the battery before it reaches its full run time and capacity.. What are you running them in? motor size and veh play allot with it

    Quote Originally Posted by rhardy60 View Post
    Try recycling the battery's and a slow charge at 1 amp . Sometimes that well bring them back to life .
    Tryed everything even spent money on another charger thinking the second charger was bad as well

  6. #6
    RC Qualifier
    Join Date
    May 2011
    Posts
    374
    I'm running them in my emaxx with stock 550 motors
    The smartest person, asks the most questions...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •