Results 1 to 5 of 5
  1. #1
    RC poster
    Join Date
    Feb 2013
    Posts
    1

    Revo 2.5 and Tqi help

    I tried installing new Tqi with dock and 4 channel 2.4ghz on my revo 2.5 they both came off brand new revo 3.3. I replaced the old am reciever and remote. I am having major troubles with it. I can't get servos or optidrive to work right. I have full brake and hesitate throttle till about 1/4 and then backs off I have steering. I heard the optidrive needs replaced with newer one with red lettering set button. I am not sure tho. I am so confused. Please help!

  2. #2
    RC Competitor
    Join Date
    Feb 2013
    Location
    Burnt fork, Wyoming
    Posts
    66
    before buying new parts if you have a spare RX pack I would try that and see if the old RX pack is weak and may not put out enough volts to over come the return spring on the throttle. As for the optidrive it might not work when there is a lower voltage idk just a though you might want to try... let us know how it goes.

  3. #3
    RC Qualifier
    Join Date
    Mar 2010
    Location
    Angleton, Tx
    Posts
    373
    I have an older revo and had similar problems when I upgraded to trx link 2.4. Mine wouldn't turn left nor open the throttle enough to hit 2nd gear despite setting and resetting end points. I gave up and went back to my old rx/tx and al issues went away. I'm going to keep an eye on this thread for a solution because I want to upgrade.
    Revo 3.3

  4. #4
    Marshal Double G's Avatar
    Join Date
    May 2008
    Location
    Putting the water on the hot stuff
    Posts
    9,698
    Remove the Opti-Drive and be sure not to switch to reverse while driving forward. Replacing the radio is that simple. Once it is plugged in, look through the manual to link them together and then go.
    The Super Derecho

  5. #5
    RC Racer
    Join Date
    Jan 2013
    Location
    milwaukee wisconsin
    Posts
    169
    if your worried about switching the tranny into reverse while going foward let me know, there is a really easy mod that can fix that without the opti-drive

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •