Results 1 to 9 of 9
  1. #1
    RC Qualifier
    Join Date
    Dec 2012
    Posts
    469

    Controller blinks

    I got a 2.4ghz radio and its the tq with the flip antena the car works and so does the radio but the remote blinks the entire time?.fresh set of batteries to.

  2. #2
    RC Turnbuckle Jr. JimmyNeutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, Michigan
    Posts
    12,291
    What color?
    Whatever it is I just typed... could be wrong.

  3. #3
    RC Qualifier
    Join Date
    Dec 2012
    Posts
    469
    Green its just like a slow blink but condistent..

    Everything works good though. On the esc of the car its lights green to. Until u push forward or reverse the light goes away. But everything works great..

  4. #4
    RC Qualifier
    Join Date
    Dec 2012
    Posts
    469
    Consistent i meant.

  5. #5
    RC Turnbuckle Jr. JimmyNeutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, Michigan
    Posts
    12,291
    The ESC light is supposed to go off when in the middle range of throttle. It is supposed to relight when at neutral, maximum forward, and maximum reverse.

    Transmitter LED Codes
    Solid Green = Normal Driving Mode
    Slow Red = Binding Mode
    Fast Blinking Red = Link Error/Failure
    Blinking Red = Low Battery Alarm
    Blinking Green = Neutral Out of Range
    Whatever it is I just typed... could be wrong.

  6. #6
    RC Qualifier
    Join Date
    Dec 2012
    Posts
    469
    Quote Originally Posted by Jimmie Neutron View Post
    The ESC light is supposed to go off when in the middle range of throttle. It is supposed to relight when at neutral, maximum forward, and maximum reverse.

    Transmitter LED Codes
    Solid Green = Normal Driving Mode
    Slow Red = Binding Mode
    Fast Blinking Red = Link Error/Failure
    Blinking Red = Low Battery Alarm
    Blinking Green = Neutral Out of Range
    So what does neutral out of range mean

  7. #7
    RC Qualifier
    Join Date
    Dec 2012
    Posts
    469
    Hey guys i found a paper in remote with instructions i set to factory defaults and all is good now. The esc is green and on full yhrottle or full reverse it turns green again and the remote is just solid. Thanks

  8. #8
    RC Turnbuckle Jr. JimmyNeutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, Michigan
    Posts
    12,291
    Glad you got it figured out!
    Whatever it is I just typed... could be wrong.

  9. #9
    RC Qualifier
    Join Date
    Apr 2012
    Location
    Salisbury, NC
    Posts
    633
    Quote Originally Posted by brandon32689 View Post
    Hey guys i found a paper in remote with instructions i set to factory defaults and all is good now. The esc is green and on full yhrottle or full reverse it turns green again and the remote is just solid. Thanks
    When it was blinking green, it was trying to tell you throttle trim was not set right. When this happens, the right knob defaults to that so you can fix it. Adjust it until its constant green, then hit save. Turn everything off/on and that's all you need to do and the knob will default back to whatever you had it set to. I just had to go through that when I got a new transmitter.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •