Results 1 to 5 of 5

Thread: servo problems

  1. #1
    RC poster
    Join Date
    Feb 2013
    Posts
    12

    servo problems

    I Went OUt Today And Played With My Truck A Bit It Just Rained ATon Here In Az I First Starter My Truck And Had NoProblems But Now I Have No Servos At All They Acted Funny When I Was Driving And Kind Of Gave Out Then To I Got Home And Cleaned My Truck As It Had Gotten A Little Muddy And Then I Put New Batteries In It And Still Having The Same Problem Im Gonna Let My Truck Dry Out Over Night And Im Gonna See What's Up When I Wake Up Anyone Have An Idea Of What It Might Be

  2. #2
    RC Champion
    Join Date
    Jan 2013
    Location
    Buffalo NY
    Posts
    1,330
    You might want to open your receiver box and let that dry out as well. Even though it's "waterproof," something might have gotten in there. Let things dry out and get back to us.
    Make it idiot-proof and along comes a better idiot

  3. #3
    RC poster
    Join Date
    Feb 2013
    Posts
    12
    Yea Letting It Dry Out Worked But Then I Broke It lol

  4. #4
    RC Competitor
    Join Date
    Nov 2012
    Location
    Albury, Australia
    Posts
    67
    What exactly broke? Did you short circuit the electronics?
    ---------------
    Traxxas Slayer Pro 4x4

  5. #5
    RC poster
    Join Date
    Feb 2013
    Posts
    12
    I Broke The Upper A Arm And CarrierBearing Assembly Slid Into A Car Sideways (edited out asterisks) Thur Thing Is Tough

    If the language filter replaces a word or ANY text with an asterisk you need to change it. DO not substitute letters or use mis-spelling to work around the filter either. That too will give you points. You have 45 minutes to edit your posts
    Last edited by Nitronaught; 02-26-2013 at 10:57 AM. Reason: language filter

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •