Results 1 to 4 of 4
  1. #1
    RC Competitor
    Join Date
    Dec 2012
    Location
    Cyprus
    Posts
    94

    problem with 2cell/3cell traxxas charger

    Hello
    i seem to have a problem with the 2cell/3cell traxxas charger that comes along with the bandit VXL..
    I have two batteries, one 2 cell and one 3 cell..

    I dont know if you guys are familiar with this charger but when its turned one it has three green blinking lights that assure you that its ready to charge..
    When you connect a battery then the lights will turn red indicating that the charger is charging the cells..
    When its finished charging then the lights turn green..

    The problem is that with both my batteries not all lights (one for each cell) turn green after charging cycle is finished..
    And this translated to not charging all cells the same...bring the low voltage protection really early..i mean the 3cell 6500mah battery brought the LVP after 4 mins..and the 3300mah 2cell wont even work as it brings up the LVP as soon as the ESC is on..

    I used a friend's professional charger to charge my batteries and everything was fine...
    so something is wrong with the charger!

    Does anyone else have a similar problem with this charger?

  2. #2
    RC Champion
    Join Date
    Jan 2013
    Location
    Buffalo NY
    Posts
    1,330
    Get yourself a Traxxas EZ Peak Plus...it's the best 80 bucks or so you'll spend in this hobby!
    Make it idiot-proof and along comes a better idiot

  3. #3
    RC Champion
    Join Date
    Mar 2011
    Location
    Zeeland Michigan
    Posts
    1,149
    Quote Originally Posted by kasapomashero View Post
    Hello
    i seem to have a problem with the 2cell/3cell traxxas charger that comes along with the bandit VXL..
    I have two batteries, one 2 cell and one 3 cell..

    I dont know if you guys are familiar with this charger but when its turned one it has three green blinking lights that assure you that its ready to charge..
    When you connect a battery then the lights will turn red indicating that the charger is charging the cells..
    When its finished charging then the lights turn green..

    The problem is that with both my batteries not all lights (one for each cell) turn green after charging cycle is finished..
    And this translated to not charging all cells the same...bring the low voltage protection really early..i mean the 3cell 6500mah battery brought the LVP after 4 mins..and the 3300mah 2cell wont even work as it brings up the LVP as soon as the ESC is on..

    I used a friend's professional charger to charge my batteries and everything was fine...
    so something is wrong with the charger!

    Does anyone else have a similar problem with this charger?
    It well that about 6 to 8 hrs to charge a 2s it took almost 9hrs to charge my 3s 5000 mah . Hv to to wait until lights turn green 2s 2 green lights 3s all lights turn green . But a different chager i would look at .
    Last edited by rhardy60; 02-17-2013 at 05:07 PM.
    1 Rusty VXL

  4. #4
    RC Competitor
    Join Date
    Dec 2012
    Location
    Cyprus
    Posts
    94
    got myself today this charger..
    http://www.milleniumrc.fr/media/notices/ORI30184.pdf

    Will post back and say if the problem is solved with this charger..
    Or else something is wrong with the 2s battery..

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •