Results 1 to 16 of 16
  1. #1
    RC Qualifier
    Join Date
    May 2011
    Posts
    626

    HELP!! something is messed up AGAIN

    1/16 brushless revo, full charged battery, truck driving SLOW like 1 mph . the thingy with the power button on it on the truck ( whats that called) is heating up ALOT, so I think i need a one of them. Whats a good direct bolt on replacement?


    Charge battery, put in cold vehicle, the thingy with the power button gets hot as heck.
    Last edited by ksb51rl; 02-17-2013 at 12:42 PM. Reason: Language

  2. #2
    RC Racer
    Join Date
    Oct 2012
    Location
    Coleman AB
    Posts
    109
    I think your looking for ESC Electric Speed Control

    here is a replacement if you REALLY need it
    http://www.ebay.com/itm/Traxxas-3375...item1e773b6736
    Last edited by DrakeBahamut; 02-17-2013 at 12:46 AM.
    Summit
    Slash
    merv x3
    savage flux xs

  3. #3
    RC Turnbuckle Jr.
    Join Date
    Mar 2012
    Location
    so cal
    Posts
    9,244
    Try unplugging the servo. Solves a lot of esc problems

  4. #4
    RC Racer
    Join Date
    Jan 2013
    Posts
    185
    Really? A servo can messes up the esc?
    Watch Out!!! My merv is a little green Hulk.

  5. #5
    RC Turnbuckle Jr.
    Join Date
    Mar 2012
    Location
    so cal
    Posts
    9,244
    Absolutely!

  6. #6
    RC Racer
    Join Date
    Jan 2013
    Posts
    185
    So, what is it, Knall? Did you unplug the servo? Is the thingy still hot?
    Watch Out!!! My merv is a little green Hulk.

  7. #7
    RC Qualifier
    Join Date
    May 2011
    Posts
    626
    havent tried that yet, but the steering works.

  8. #8
    RC Racer
    Join Date
    Oct 2012
    Location
    Coleman AB
    Posts
    109
    the steering can/will still work sometimes even if something is wrong with it. It can still be the problem even though it seems to be fine
    Summit
    Slash
    merv x3
    savage flux xs

  9. #9
    RC Qualifier
    Join Date
    May 2011
    Posts
    626
    OK, i unplugged the steering servo no change, I recalibrated esc no change. I even put it in training mode, way way way slower.

    Tried 3 diferant batteries, everything works fine but its going 1 mph what is going on??

  10. #10
    RC Turnbuckle Jr.
    Join Date
    Mar 2012
    Location
    so cal
    Posts
    9,244
    Does either the motor or esc get got?

  11. #11
    RC Qualifier
    Join Date
    May 2011
    Posts
    626
    not at the moment, no. not running fast enough to get warm

  12. #12
    RC Turnbuckle Jr.
    Join Date
    Mar 2012
    Location
    so cal
    Posts
    9,244
    If the motor was wasted it would get hot going 1mph
    Same slow speed in reverse?
    Try pulling the motor away from the spur does it sound slow

  13. #13
    RC Qualifier
    Join Date
    May 2011
    Posts
    626
    yes slow in reverse also. Motor is running slow , but I suspect the esc

  14. #14
    RC Turnbuckle Jr.
    Join Date
    Mar 2012
    Location
    so cal
    Posts
    9,244
    Sounds like it. Good time to upgrade to a better esc like the mmp

  15. #15
    RC Qualifier
    Join Date
    May 2011
    Posts
    626
    New to electric whats a mmp?

  16. #16
    RC Turnbuckle Jr.
    Join Date
    Mar 2012
    Location
    so cal
    Posts
    9,244
    Mamba max pro

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •