Results 1 to 8 of 8
  1. #1
    RC Competitor
    Join Date
    Dec 2012
    Location
    Jacksonville,NC
    Posts
    80

    ez peak plus problem...HELP

    just got this new charger and I'm getting a "connection break" error everytime I go to charge.I've tried balance,quick,and storage charge modes and nothing.Ive tried 3 different packs and there all the same.I checked all the wires to the balance board and all plugs.Can anyone help?

  2. #2
    RC Champion
    Join Date
    Jan 2013
    Location
    Buffalo NY
    Posts
    1,330
    Connection break means you've potentially got a bad battery connector, broken charge lead wire, or did a poor soldering job (assuming you soldered your own connectors).

    I've had this happen a few times myself...although it is possible there's a problem with the charger!
    Make it idiot-proof and along comes a better idiot

  3. #3
    RC Competitor
    Join Date
    Dec 2012
    Location
    Jacksonville,NC
    Posts
    80
    well my other charger has no problems chrging the same batteries

  4. #4
    RC Champion
    Join Date
    Jan 2013
    Location
    Buffalo NY
    Posts
    1,330
    Quote Originally Posted by lance0206 View Post
    well my other charger has no problems chrging the same batteries
    Are you using the same charge leads and connectors? If so, something tells me your E-Z Peak Plus was DOA!
    Make it idiot-proof and along comes a better idiot

  5. #5
    RC Competitor
    Join Date
    Dec 2012
    Location
    Jacksonville,NC
    Posts
    80
    think I figured it out I was trying to charge through just the balance port without plugging the leads up that come from the battery.Is this correct?

  6. #6
    RC Champion
    Join Date
    Jan 2013
    Location
    Buffalo NY
    Posts
    1,330
    Quote Originally Posted by lance0206 View Post
    think I figured it out I was trying to charge through just the balance port without plugging the leads up that come from the battery.Is this correct?
    LOL! Yes, that would be your problem my friend...been there, done that. Chalk it up to experience!
    Make it idiot-proof and along comes a better idiot

  7. #7
    RC Competitor
    Join Date
    Dec 2012
    Location
    Jacksonville,NC
    Posts
    80
    yep got it to work and that was it.lol I'm used to my other charger being able to charge through the balance port.oh well live and learn anyway thanks for the help!

  8. #8
    RC Champion
    Join Date
    Jan 2013
    Location
    Buffalo NY
    Posts
    1,330
    Quote Originally Posted by lance0206 View Post
    yep got it to work and that was it.lol I'm used to my other charger being able to charge through the balance port.oh well live and learn anyway thanks for the help!
    Anytime!
    Make it idiot-proof and along comes a better idiot

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •