Results 1 to 8 of 8

Thread: ESC Problem

Hybrid View

  1. #1
    RC Racer
    Join Date
    Dec 2012
    Location
    Chicago, IL
    Posts
    249

    ESC Problem

    Ok folks... Need help... I recently added the CC External BEC to my XO-1 and followed directions to the letter. Disconnected the power wire from the ESC and using a Y adapter connected both BEC and ESC to the receiver(Rx) slot #2. Now the issues I have is that the ESC will NOT ARM (all lights flashing) when I turn it on. For the ESC to Arm I have to leave the ESC switched on all the time and Only when I connect the batteries it will arm. The interesting thing is I have the EXACT same set-up in my HPI Vorza and I have no problems ... What am I doing wrong? Let me know how to solve this... I called Traxxas and they say its Castle's problem... called Castle and they say that the ESC is not seeing the Rx... Thing is, when I leave the ESC switch on and then connect the batteries, it arms but once the switch is off I connect the batteries and then turn the ESC switch on it WILL NOT ARM... I spent more money on another Rx, another BEC and Castle Link field connect where I updated the firmware and increased the BEC to 6 volts for my Savox servo ALL in vain.... Let me know what you folks think and how I can fix this....




    XO-1/jato 3.3/TMaxx picco jl red dot/ofna lx2/ HPI Vorza flux
    Last edited by XO-1 MD; 02-08-2013 at 10:42 PM.

  2. #2
    RC Champion
    Join Date
    Jul 2007
    Location
    Rc Room
    Posts
    1,484
    Watch the led on the RX. red=bad, green=good Something like that I ditched the factory radio a long time ago. It may be a CLL conflict. GL2U
    Last edited by BL-Bob; 02-10-2013 at 12:13 PM.
    Stop busting my canards!

  3. #3
    RC Racer
    Join Date
    Dec 2012
    Location
    Chicago, IL
    Posts
    249
    Sent ESC back to castle today... will see what happens...

  4. #4
    RC Champion
    Join Date
    Jan 2013
    Location
    Buffalo NY
    Posts
    1,330
    Quote Originally Posted by XO-1 MD View Post
    Sent ESC back to castle today... will see what happens...
    I'd be surprised if they don't take good care of you. I had a problem with Castle Link maybe two weeks ago and got a refund fast. They've always been top-notch in my years of R/C.
    Make it idiot-proof and along comes a better idiot

  5. #5
    RC Racer
    Join Date
    Dec 2012
    Location
    Chicago, IL
    Posts
    249
    Wow... Castle Creations just sent me a new ESC... Indeed... A customer for life... I will be buying the XL2 1/5 ESC as my next XO-1 upgrade... Yeah!

  6. #6
    RC Qualifier
    Join Date
    Feb 2012
    Posts
    692
    Quote Originally Posted by XO-1 MD View Post
    Wow... Castle Creations just sent me a new ESC... Indeed... A customer for life... I will be buying the XL2 1/5 ESC as my next XO-1 upgrade... Yeah!
    let me know before you buy one I just sold my brand new xo1 roller and have a brand new xl2 never used just soldered the connectors on it .
    XO-1,SLASH 4X4 ,SLASH 2WD , 2/RUSTLER

  7. #7
    RC Champion
    Join Date
    Jul 2007
    Location
    Rc Room
    Posts
    1,484
    Quote Originally Posted by XO-1 MD View Post
    Wow... Castle Creations just sent me a new ESC... Indeed... A customer for life... I will be buying the XL2 1/5 ESC as my next XO-1 upgrade... Yeah!
    That's sweet, Castle is awesome!

  8. #8
    RC Champion
    Join Date
    Jan 2013
    Location
    Buffalo NY
    Posts
    1,330
    Glad it worked out!
    Make it idiot-proof and along comes a better idiot

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •