Results 1 to 11 of 11
  1. #1
    RC Enthusiast
    Join Date
    Mar 2013
    Posts
    35

    Charging a new Venom 8.4 5000Mah Nimh

    Just got a new venom batter last night, put it on the quick charger. The charger showed it as being done, but when I tried to run the RC it took off then immediately slowed down and became very glitchy. Does a new battery require a little extra charge or is there possibly something wrong with my rusty. I'm running a new Radient Reaktor brushless system, I dont have a heat gun and I have been playing with the gearing a bit. I have made sure to give it the hand test every few minutes when running this system with a 26T pinion and 83T spur. It got pretty warm but didnt seem to be to the point of to hot. Any ideas?

    P.S. Im very new to the RC scene so if my questions seem ignorant, I apologise.

    Thanks in advance for any advice.
    Last edited by Dadx2mj; 03-08-2013 at 10:18 AM. Reason: Language

  2. #2
    Marshal Dadx2mj's Avatar
    Join Date
    Aug 2007
    Location
    So Cal
    Posts
    21,199
    What you describe does not sound like anything to do with using or charging a new battery.

    I would try recalibrating the radio and ESC and checking all the setting on your radio.
    BlindMan Racing
    Rusty - MERV - Pede 4x4-Alias
    SPC Lipo Power

  3. #3
    RC Competitor
    Join Date
    Feb 2013
    Location
    In my room with this internet machine
    Posts
    93
    I once had a new 8.4v 7cell nimh battery and a new charger, and I thought they gave it to me charged because charger showed it as done in 5 minutes. I plugged it in my rusty and it wouldn't even budge. I put it back on the charger and this time it charged for bout an hour before it showed it as done. Then it worked fine.

  4. #4
    RC Enthusiast
    Join Date
    Mar 2013
    Posts
    35
    Quote Originally Posted by Dadx2mj View Post
    What you describe does not sound like anything to do with using or charging a new battery.

    I would try recalibrating the radio and ESC and checking all the setting on your radio.
    I'll give that a try, thanks.

  5. #5
    RC Enthusiast
    Join Date
    Mar 2013
    Posts
    35
    Quote Originally Posted by iGoRusty View Post
    I once had a new 8.4v 7cell nimh battery and a new charger, and I thought they gave it to me charged because charger showed it as done in 5 minutes. I plugged it in my rusty and it wouldn't even budge. I put it back on the charger and this time it charged for bout an hour before it showed it as done. Then it worked fine.
    That was my first thought, when I plugged it in before I went to bed the charging light was on for at least 15 minutes before I fell asleep. Hopefully thats all it is. Thanks!

  6. #6
    RC Racer
    Join Date
    May 2012
    Posts
    101
    that's all it should be bud, if your new into the RC world, Look into getting lipos and a charger that's where its best to start out with

  7. #7
    RC Enthusiast
    Join Date
    Mar 2013
    Posts
    35
    Quote Originally Posted by bdion626 View Post
    that's all it should be bud, if your new into the RC world, Look into getting lipos and a charger that's where its best to start out with
    Thats what I've been hearing, kinda disappointedI got another Nimh. I'm pretty sure the charger I have now is Lipo compatible. I just ordered a Castle creations 5700KV brushless system as well as a glitch buster and cooling fan, any idea what battery would be the best match for it?

  8. #8
    RC Competitor
    Join Date
    Feb 2013
    Location
    In my room with this internet machine
    Posts
    93
    I'd go with 2s lipo for bashing, and 3s for speed runs and such.

  9. #9
    RC Turnbuckle Jr. O.G.'s Avatar
    Join Date
    Nov 2010
    Location
    South of St Louis
    Posts
    5,986
    Did you forget to take the esc off nimh mode? That's what it sounds like to me. The nimh setting will cut off a lipo too soon and make it appear the battery is prematurely dead.
    My Black & Blue Rally is faster than your color...

  10. #10
    RC Champion
    Join Date
    Mar 2011
    Location
    Zeeland Michigan
    Posts
    1,196
    ESC light , lipo is green an Nimh is red . Better charger is the best way to go , those wall charger aren't that good VERY SLOW .
    1 Rusty VXL

  11. #11
    RC Enthusiast
    Join Date
    Mar 2013
    Posts
    35
    Thanks for all the responses I got it figured out, then proceeded to fry the motor :/ lesson learned. Thanks again.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •