Results 1 to 3 of 3
  1. #1
    traxxas emaxx
    Guest

    i need alll the help i can get!!!!

    hey all so I got the qr1 for Christmas and haven't had any bad crashes and went to fly it the other day and it would fly for 2 seconds then drop and say my batteries are dead when I just charged them? What should I do to fix this and has this happened to you??

  2. #2
    RC Qualifier
    Join Date
    Oct 2011
    Location
    Vermont
    Posts
    725
    Call traxxas? Maybe it's your transmitter?

  3. #3
    Traxxas Employee Propsmoke's Avatar
    Join Date
    Feb 2010
    Posts
    50
    Check to make sure all 4 motors spin freely when you flick the props with your finger. If not, check the support page for the QR-1. There is a motor armature adjustment video that explains how to fix that. If they all spin freely than check your battery voltage with a multi-tester or volt-meter just to make sure your batteries are taking a charge and that the battery charger is working properly. If they are indeed fully charged they should read between 4.15 and 4.20 volts. If they are less than 4 volts they are not taking a charge. If both of them are low it is probably a problem with the charger. If all of this checks out ok than I would suggest calling Traxxas and making arrangements to send in your QR-1 and transmitter for diagnosis. That is what we are here for!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •