Results 1 to 2 of 2
  1. #1
    RC poster
    Join Date
    Jan 2013
    Posts
    1

    Nitro 4-Tech Cleaning the engine!

    Hello guys. what i did to my 4tech engine is i took it off from the car, cleaned the outside with WD40 then placed it back and then tried to start it. went pretty fine but after few minutes, smoke appeared from the engine (not from the exhaust). removed the blue part of the the engine (i dont know what is the exact term, cooling system) to the check the piston and glow plug as well and everything seems fine. my question is, is the smoke came from wd40 which i used to clean the outside of the engine due to heat after running or is my engine broken? please help. really bothered with my car.

  2. #2
    RC Champion
    Join Date
    Mar 2010
    Location
    Hackettstown,NJ
    Posts
    1,436
    yes, the smoke is from the wd40.. Not sure why you would use that to clean the outside of the motor, they make specific products for that or you can simple green diluted with water or with denatured alcohol..spray the outside of the motor, use a brush to work it in then clean it with compressed air your done..The motor will really clean up well and will not smoke from the oils in wd40.. You want to use wd40 on the plastic arms and metal drive parts, not the motor.
    Maxx3.3/ rusty5700/ slash3800/ slash5700 /4tec3.3

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •