Results 1 to 8 of 8

Thread: No fuel?

  1. #1
    RC poster
    Join Date
    Jan 2013
    Posts
    7

    Question No fuel?

    Got my Revo 3.3 out of storage, charged every thing up, fueled it. Tried to start it. Cranks fine, but won't pull fuel from tank to carburetor? Dad says he had same problem, had to replace piston rod and that worked. So that's what I did. Didn't work?
    Ideas?
    Last edited by rdhowdy; 01-24-2013 at 08:38 PM. Reason: Spelling

  2. #2
    RC Champion
    Join Date
    Jan 2013
    Location
    Buffalo NY
    Posts
    1,330
    Cracked fuel line perhaps?
    Make it idiot-proof and along comes a better idiot

  3. #3
    RC poster
    Join Date
    Jan 2013
    Posts
    7
    Quote Originally Posted by zippogeek View Post
    Cracked fuel line perhaps?
    That was my first thought. I blew into the line from exhaust to fuel tank which filled the fuel lines, to check for leaks, didn't find any.
    Last edited by rdhowdy; 01-24-2013 at 09:17 PM. Reason: Spelling

  4. #4
    RC Enthusiast
    Join Date
    Jan 2013
    Posts
    37
    try blowing the fuel to the engine through the exhaust line. This should get it started. It could be the seal around the fuel tank cap. First how did you try to prime the engine, over the exhaust or the carburetor intake?

  5. #5
    RC Qualifier
    Join Date
    Dec 2011
    Location
    Woodward, OK
    Posts
    494
    You could have a leak in the exhaust at the coupler, at the header, or your fuel cap could not be sealing. Did you change the piston and sleave, or the rod?

    sent from my not so smart, smart phone
    Rusty 2.5R,T-max 2.5 & 3.3,Summit VXL Nitro 4-tec

  6. #6
    RC poster
    Join Date
    Jan 2013
    Posts
    7
    Quote Originally Posted by Rcracing6575 View Post
    try blowing the fuel to the engine through the exhaust line. This should get it started. It could be the seal around the fuel tank cap. First how did you try to prime the engine, over the exhaust or the carburetor intake?
    Primed by finger on exhaust. Blew fuel through exhaust line, then battery died, so will try that.

  7. #7
    RC poster
    Join Date
    Jan 2013
    Posts
    7
    Quote Originally Posted by westoakmech View Post
    You could have a leak in the exhaust at the coupler, at the header, or your fuel cap could not be sealing. Did you change the piston and sleave, or the rod?

    sent from my not so smart, smart phone
    I did replace piston and sleeve along with the piston rod. Ill double check header and exhaust

  8. #8
    RC Champion
    Join Date
    Apr 2011
    Posts
    1,994
    Maybe you need to crack the throttle a little bit. Sometimes the tiny passage through the lsn can plug up, so you may want to see if it will pull fuel with the slide open a bit.
    erbe emaxx 26maxx s27revo 18tmrevo XXL platinum

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •