Results 1 to 7 of 7

Thread: wont link!

  1. #1
    RC Enthusiast
    Join Date
    Dec 2012
    Posts
    28

    wont link!

    hey, a little help here.i bought a 2.4 tx and rx new off ebay and cant get em to link. batteries are fresh and my proceedure is correct. the tx is a tq and rx ix is a tqi. seller says they are compatable.any thoughts?

  2. #2
    RC Champion
    Join Date
    Jan 2013
    Location
    Buffalo NY
    Posts
    1,330
    Are you doing it like this?

    http://traxxas.com/support/How-do-I-...itter-receiver

    Also, just to make sure it's compatible:

    http://traxxas.com/support/Traxxas-T...tibility-Guide
    Make it idiot-proof and along comes a better idiot

  3. #3
    RC Enthusiast
    Join Date
    Dec 2012
    Posts
    28
    yeah i saw that and informed seller, but he assured me that the 6518 rx would work with all newer tx.obviously not. this guy is selling these combos on ebay for 29 + 10 for shipping. guess he got me. im a newbie and learning the hard way.Pays to be patient.

  4. #4
    RC Champion
    Join Date
    Jan 2013
    Location
    Buffalo NY
    Posts
    1,330
    Do you have a LHS (Local Hobby Shop?) Sometimes, when you're new to R/C, you're better off going there. You'll pay a little more, but you'll get good advice...
    Make it idiot-proof and along comes a better idiot

  5. #5
    RC Enthusiast
    Join Date
    Dec 2012
    Posts
    28
    thanks for reply.

  6. #6
    RC Qualifier
    Join Date
    Apr 2012
    Location
    Salisbury, NC
    Posts
    633
    Quote Originally Posted by zippogeek View Post
    I have the same problem and did do it like this (several times) and still no dice. I did get the newer radio that came with the TQi trans to link up with my old 2.4 GHz trans, and then got the old trans to link up with the new radio. I can run either truck with the old radio, but can't get the new trans. to hook up and work with either. I guess I'll have to call Traxxas support unless anyone has any other ideas.
    I get a flashing green light on the ESC that indicates throttel trim not set right. I set that up per the instructions for that, and then when I program the ESC, it stops at setting the reverse on the trigger and doesn't complete the programming. Same thing happens on both truck's systems, so it's got to be the transmitter giving a false indication or something.

  7. #7
    RC Qualifier
    Join Date
    Apr 2012
    Location
    Salisbury, NC
    Posts
    633
    Quote Originally Posted by blumule View Post
    hey, a little help here.i bought a 2.4 tx and rx new off ebay and cant get em to link. batteries are fresh and my proceedure is correct. the tx is a tq and rx ix is a tqi. seller says they are compatable.any thoughts?
    Same exact thing happened to me with a new transmitter and radio I bought off ebay. No problem getting the radio to work with my old transmitter, but the new transmitter won't work with either radio.
    I'm in business now. Apparently, sometimes when you get a new transmitter there is a special procedure that needs to be done that Traxxas doesn't publish. They don't publish it because if you do it wrong, the result can be irreparable damage to the transmitter. Traxxas Support had me do a bunch of button pushing, and then went through rebinding and ESC calibration and the new transmitter is now working fine with my new receiver and also the one in my other truck.
    I don't think I'll ever buy anything RC that isn't Traxxas again. I did once and it was a bad experience. Traxxas always makes it right.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •