Results 1 to 13 of 13
  1. #1
    RC Qualifier
    Join Date
    Dec 2012
    Location
    Sacramento, CA
    Posts
    592

    Low Radio Range?

    Out driving my new Summit today again. Truck is performing amazing, but I noticed I seem to keep losing radio contract with the truck with the stock TQi system after as close a distance as 60ft. Usually it is more goes out to around 100ft at most then its lost and the truck enters fail safe mode.

    Any suggestions? I have brand new duracell alkaline batteries in there. Only mod on the truck is the addition of the roof light bar.

    Thanks

  2. #2
    RC Turnbuckle Jr. JimmyNeutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, Michigan
    Posts
    12,290
    Cold out?
    Running LiPo or NiMh?
    Antenna wire damaged?
    Whatever it is I just typed... could be wrong.

  3. #3
    RC Qualifier
    Join Date
    Dec 2012
    Location
    Sacramento, CA
    Posts
    592
    Yeah it's cool. Low 50's

    Happens on Nimh and lipo

    No damage to the antenna

  4. #4
    RC Turnbuckle Jr. JimmyNeutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, Michigan
    Posts
    12,290
    There was a batch of TQi radios that had bad range.
    Hopefully you are in the states so it makes sense to contact Traxxas for a warranty swap.


    Cold... 30-40F can effect batteries a LOT more than most realize. Creating low voltage issues even when resting voltage is where it should be.

    Damaged wires effect range... so take care of those delicate little things!!
    Whatever it is I just typed... could be wrong.

  5. #5
    RC Qualifier
    Join Date
    Dec 2012
    Location
    Sacramento, CA
    Posts
    592
    I called Traxxas support and asked me to try 2 things first before replacement.

    1. I'm using brand new Duracell alkaline batteries. But they want me to try energizer brand batteries because they said they are higher quality. Also they said theybareboh so slightly larger and may make better contact with the springs in the battery compartment.
    2. If that doesn't help the problem they said to rebind the radio to the truck and seeing that fixes it. Does anyone know how to rebind? How do I power up the receiver to rebind?

    If that doesn't work call traxxas back and they will talk replacement.

    Well see

  6. #6
    RC Qualifier
    Join Date
    Mar 2012
    Location
    Chehalis, Wa
    Posts
    436
    Quote Originally Posted by Sactown_Summit View Post
    2. If that doesn't help the problem they said to rebind the radio to the truck and seeing that fixes it. Does anyone know how to rebind? How do I power up the receiver to rebind?

    Well see
    Have the both the romote and summit off. Hold the set button down on the romote and turn it on. Red slow light will blink.
    On the summit you'll have to take the RX cover off and hold don't the set button while turning your summit on. Red light on RX will blink slow.
    Have the summit and remot within 3 feet of each other. It may take a minute or so but both lights should turn green. Usually mine will bind in about 5 seconds but I was told by Traxxas that it could take a bit.
    _______^_
    /______l__\____
    l_l O l_____l O l

  7. #7
    RC Qualifier
    Join Date
    Dec 2012
    Location
    Sacramento, CA
    Posts
    592
    Quote Originally Posted by Keila72 View Post
    Have the both the romote and summit off. Hold the set button down on the romote and turn it on. Red slow light will blink.
    On the summit you'll have to take the RX cover off and hold don't the set button while turning your summit on. Red light on RX will blink slow.
    Have the summit and remot within 3 feet of each other. It may take a minute or so but both lights should turn green. Usually mine will bind in about 5 seconds but I was told by Traxxas that it could take a bit.

    Thanks for the info.

    Rebound the radio today. Still have the same low distance range issues. Going to try energizers best batteries. If that doesn't work will have to call back traxxas.

    How does a warranty request like this work? Would I have to send just the radio in? Radio and receiver? Or does the whole truck have to be sent back in? Really don't want to have to package the truck back up there is nothing wrong with it. Just the tx seems to be the issue.

  8. #8
    RC Turnbuckle Jr. JimmyNeutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, Michigan
    Posts
    12,290
    A call/email into Traxxas is step one... they will give you the information you need for a return.
    Usually they have you only send the defective/suspect parts, not the entire RC.
    Whatever it is I just typed... could be wrong.

  9. #9
    RC Qualifier
    Join Date
    Dec 2012
    Location
    Sacramento, CA
    Posts
    592
    Thanks for the information. Ill give them a call to get this taken care off.

  10. #10
    RC Qualifier
    Join Date
    Mar 2012
    Location
    Chehalis, Wa
    Posts
    436
    Quote Originally Posted by Sactown_Summit View Post
    Thanks for the information. Ill give them a call to get this taken care off.
    When you had your recover box open was their any moisture in there?
    Something else to try befor you send it out is take the transmitter apart and make sure the antenna wire didn't come off the curt board. It just pops on and off.

    Here Is a link for you to read threw and it might be something to look at.
    http://traxxas.com/forums/showthread...-What-did-i-do
    _______^_
    /______l__\____
    l_l O l_____l O l

  11. #11
    RC Qualifier
    Join Date
    Dec 2012
    Location
    Sacramento, CA
    Posts
    592
    Opened up the rx box to make sure nothing was wet or torn. All was well. Took out the rx to inspect all looked good. Had nothing else to try to called Traxxas and the opened up an RMA. Dropped it off yesterday to send in. Big time bummer. One week old Summit now sitting and can't be used. Tried to look past it but for $550 figure I deserved a radio system that had more then 60 feet of reliable range.

    Now just excited to get a proper functioning tx and rx back so I can hit the dirt again. Guess ill prep the metal in the chassis for water and clean and lube the motor while I have the down time. Time to make a summit truck stand too for maintenance.

    Hope traxxas' repair house is quick?

  12. #12
    RC Qualifier
    Join Date
    Mar 2012
    Location
    Ontario
    Posts
    989
    I haven't sent mine in yet, have the same range problem, I ordered another tqi with the docking station so later I can use telemetry

    Hopefully the new ones work properly
    What's a coffee if it aint Irish

  13. #13
    RC Qualifier
    Join Date
    Dec 2012
    Location
    Sacramento, CA
    Posts
    592
    **UPDATE**

    Just got my TQI tx and rx back from Traxxas. The whole RMA process took a total of 2.5 weeks from time I sent my tx and rx in and then got it back. The repair department couldn't find anything wrong with my tx or the rx. But decided the problem must be in the rx. So they still sent me back a brand new TQI rx anyway to bind and try instead of the old one.

    Just got done installing. Range testes it. Problem GONE!!! Range is wayyyyyyyyyyyyy down the street now, so far that its gets hard to see the truck and its oreintation. And that is hard to do with how big the Summit is. I would guess range i tested out to was at least 300ft, and it could have gone further then that. Before I was losing signal as close as 70ft.

    Anyway just wanted to thank Traxxas for their great service. Kept me updated to status the whole time too with emails. Now to get back to driving!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •