Results 1 to 7 of 7
  1. #1
    RC Enthusiast
    Join Date
    Jan 2013
    Posts
    25

    Slayer Pro stuck in gear?

    Picked up a Slayer Pro used and love it but having a couple of issues that may be related. First when I start with the EZ Start it will spin and not engage the motor, like maybe the one-way bearing is bad? Then when it does engage the truck tries to move from the starter, like the clutch is stuck engaged.

    I'm comfortable with tearing it down and trying to find the problem but I wanted to ask on here first if this is a common issue and where I should start? Not sure if it's a clutch issue or trans issue.

    Thanks
    Last edited by Brodee; 01-15-2013 at 02:13 PM.

  2. #2
    RC Racer
    Join Date
    Dec 2012
    Posts
    225
    The spring that goes around the clutch shoes is the problem with it not starting unless the wheels are spinning. can't help ya as far as the ez start goes tho

    Sent from my SAMSUNG-SGH-I927 using Tapatalk 2

  3. #3
    RC Enthusiast
    Join Date
    Jan 2013
    Posts
    25
    Thanks. I ordered that spring and will tear it apart tonight.

  4. #4
    RC poster
    Join Date
    Jan 2013
    Posts
    7
    With the ez-start check the one-way like you said.. I don't know where your located but where i'm at it's been pretty cold outside.. just had the same problem on a t-maxx yesterday when i was trying to run it.. it was just way to cold outside and the one-way bearing wouldn't engage.. took it inside warmed it up over a heater vent and tried it again.. no problem.

  5. #5
    RC Enthusiast
    Join Date
    Jan 2013
    Posts
    25
    I'm in Texas, but it has been cold, in the 40's. I have 2 slayers. One is running great, the other has a couple issues.

  6. #6
    RC Competitor
    Join Date
    Sep 2011
    Location
    Tucson, AZ
    Posts
    69
    The bearing may be binding caused by gunk build up. Take it out, clean it up and soak it in oil then reinstall (make sure it goes in the right way as there is a difference).

  7. #7
    RC Qualifier
    Join Date
    Oct 2011
    Location
    naptown
    Posts
    589
    While you have your CB off might as well replace clutch too. Cause when my spring went it was because my clutch was getting thin letting the spring wear against the CB. But if your just looking for springs I know I have spares that I got from MIP, think they had like in a package.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •