Page 4 of 4 FirstFirst ... 234
Results 121 to 134 of 134
  1. #121
    RC Racer
    Join Date
    Jan 2013
    Posts
    160
    New Rim idea coming Tuesday.

    With 2 tire options.
    1. A tire designed for the rim
    2. Proline Trenchers which should hopefully fit this new rim.

  2. #122
    RC Racer
    Join Date
    Jan 2013
    Posts
    160
    So...I destroyed my diffs Sunday. Fried my servo on Monday and my brother did his rear diff and bulkhead in.

    What servo should I try next?

  3. #123
    RC Qualifier
    Join Date
    Oct 2011
    Location
    naptown
    Posts
    587
    What servo were you running? I've been running the hitech 5085 for bout a year with no issues.

  4. #124
    RC Racer
    Join Date
    Jan 2013
    Posts
    160
    I was running an imported metal geared servo. I've been looking into both the 5085MG and the 5086WP.

  5. #125
    RC Competitor
    Join Date
    Apr 2013
    Posts
    85
    I just installed a 5086 this weekend. Install was fairly easy and this improvement over stock is noticeable at the first power up

  6. #126
    RC Racer
    Join Date
    Jan 2013
    Posts
    160

  7. #127
    RC Qualifier
    Join Date
    Oct 2011
    Location
    naptown
    Posts
    587
    Def let us know how you like them.....You don't have any extra HPI rims laying around do you? Was curious how they looked stretched on those rims.....

  8. #128
    RC Racer
    Join Date
    Jan 2013
    Posts
    160
    Well, Unfortunately it will be down for awhile with the servo and I just bought a new toy.

    For my rim. HPI WR8. Offset isnt where I'd like but I think this will be fun. Wheel isnt glued and no foam in it yet.








    My new toy. A Snap-On edition 1/10 E-Revo Brushless Edition. Used very lightly. Tool bags and stuff weren't open. Got it for an amazing price.





    Last edited by geckoboy86; 05-28-2013 at 09:12 PM. Reason: More Pics

  9. #129
    RC Racer
    Join Date
    Jan 2013
    Posts
    160
    Need some help. Got a new servo for the lil guy and its not working well. I did all the chassis mods to fit a Hitec 5086WP. I hook it up and its very glitchy. My summit lights dim dramatically when turning. Sometimes when turning left it does nothing and i must continue to go center then left to get it to turn left. It's also gets quite warm. I caught it at 150 with my IR temp gun after constant back and forth for about 3 minutes.

    My previous metal geared servo did this to me as well with the going left issues when it went. Cant remember if my temp 2080 did it before i stripped a gear in it.

  10. #130
    RC Racer
    Join Date
    May 2005
    Location
    Chatsworth GA
    Posts
    101
    Servos tend to do that when they draw more power then the ESC's BEC can put out. You may need an external BEC.

  11. #131
    RC Competitor
    Join Date
    Apr 2013
    Posts
    85
    Quote Originally Posted by Ninja View Post
    Servos tend to do that when they draw more power then the ESC's BEC can put out. You may need an external BEC.
    I have two mervs with this servo installed - I have had no such issue

  12. #132
    RC Turnbuckle Jr. Jimmie Neutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, MI
    Posts
    11,957
    Could be an issue with his servo...
    Whatever it is I just said... I could be wrong.

  13. #133
    RC poster
    Join Date
    Jul 2013
    Posts
    6
    pinched wire? hope you figure it out. I've got an extra bec i never used lying around.

    nice gold HPIs. I looked for those but you can't get them anymore.
    Last edited by PDXmerv; 07-23-2013 at 12:33 AM. Reason: specificity

Page 4 of 4 FirstFirst ... 234

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •