Results 1 to 7 of 7
  1. #1
    RC poster
    Join Date
    Jan 2013
    Posts
    10

  2. #2
    RC Turnbuckle Jr. Nitronaught's Avatar
    Join Date
    Oct 2005
    Location
    South Florida
    Posts
    18,566
    From the coloration of the piston on the sides on the inside and the color of the upper part of the conrod there's basically one thing that causes this... High temps.....

    It is possible and common for people to not pay attention to tuning the LSN and leaving it at factory settings while tuning the HSN only and setting the idle.. IF you have a lean LSN you can see nice smoke trails, poor performance and high temps at the glow plug.... The skirt of the piston has the least amount of material on it, this makes it the part that would be most affected by heat and become brittle with operating temps over 290 F.

    Thing is, it may not have been caused immediately, the material could have been weakened by previous runs and not let go until later, the pieces of the damaged and brittle skirt break off lodge into areas of the internals causing a lot of resistance and splitting the conrod....


    If it's a new engine and you feel this is not the case, you can call Traxxas support, they will probably ask you to send the engine in, and in many cases I've seen them replaced.. Not all but many that I would not have...

    What operating temps were you experiencing?
    Founder of H.U.A.
    Hop Ups Anonymous

  3. #3
    RC poster
    Join Date
    Jan 2013
    Posts
    10
    Thanks for the replay. the Temp was OK i guess.

    i am not sure what Traxxas can do. I live in Israel - I bought the car in US. Sending the motor will cost as new engine….

  4. #4
    RC poster
    Join Date
    Jan 2013
    Posts
    10
    That is real dark for just 1 bottle! I'd say tune, temp and almost a for sure free rev with no resistance and the rod split first breaking the skirt.

  5. #5
    RC Enthusiast
    Join Date
    Jan 2013
    Posts
    37
    Not to bash traxxas. I have been runing traxxas products since 2007 and the only thing I see wrong is that the 3.3 is the connecting rod is not strong enough to with stand tuning errors. I have blown a 3.3 with a split rod in 2010. and I have been run nitro since 2006. If I have to complain about anything, improve the con rod for the 3.3.

  6. #6
    RC Champion
    Join Date
    Apr 2011
    Posts
    1,994
    That engine was lean!
    erbe emaxx 26maxx s27revo 18tmrevo XXL platinum

  7. #7
    RC Champion
    Join Date
    Mar 2011
    Location
    Usquam sed hic
    Posts
    1,570
    Quote Originally Posted by oreno View Post
    Thanks for the replay. the Temp was OK i guess.

    i am not sure what Traxxas can do. I live in Israel - I bought the car in US. Sending the motor will cost as new engine….
    When you see that degree of damage to the piston, all that missing metal had to go somewhere. It would probably be best to do the swap and get a new one. Sorry to hear about it man
    Matthew 7:7

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •