Results 1 to 4 of 4
  1. #1
    RC poster
    Join Date
    Dec 2012
    Posts
    3

    tmaxx 3.3 seems to keep slippin and wont go plshelp

    i havent had the maxx 3.3 long i threw the pads off during break in so i put new ones on and made it a little tighter didnt have that problem again drove it about 5 more tanks the primary shaft twisted and broke just took tranny apart and replaced it put everything back together..now idrive it and like 30 sec in its just revin up..so i tightin slipper up some more..same thing over and over again..im at a stand still dont knowwhat to do im determined to doit myself so pls help???????

  2. #2
    RC poster
    Join Date
    Dec 2012
    Posts
    14
    Check the clutch on the motor. Pop off the e clip and slide off gear. MAke sure springs are not grinding into bell gear.

    The slipper should be set to where its difficult to turn by hand when the shaft is locked. TIP USE BLUE LOCKTITE ON NYLON NUT. MINE FELL OFF TWICE!!!

  3. #3
    RC poster
    Join Date
    Dec 2012
    Posts
    3
    ive had this thing in a million pieces lol...i checked the cluthbell like you said then decided to go back into tranny 4th time...
    it was the little pin behind slipper wheel i forgot to put back in well didnt forget i was just following diagram to close..it doesnt show the pin on diagram lol put it in and boom action thank you very much for help

  4. #4
    RC Turnbuckle Jr. Wildman4910's Avatar
    Join Date
    Jun 2009
    Location
    Cocoa Florida
    Posts
    4,031
    Landing on throttle puts a lot of stress on the drive line when the slipper is set too tight.
    Try to be off throttle when landing from a jump.
    Look out for the tree/crunch!

    LiPo? Naw NITRO!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •