Results 1 to 40 of 41

Threaded View

  1. #1
    RC Competitor
    Join Date
    Dec 2012
    Location
    Dayton, Ohio USA
    Posts
    64

    Another LiPo WaterProofing Thread.....

    I know another thread.....
    I have read some threads and am probably more confused now than before.
    Here's what happened. I did some light snow bashing today running the stock LiPo battery and it ran great! Once the low voltage mode kicked in, I decided to change to my new venom 5500ma 3s 20C LiPo. It ran for a couple minutes then the Pede stopped. Noticed the speed controller blinking slow red. I knew the battery was fully charged from the night before, so I disconnected the battery and reconnected. Started running again, but only for a couple minutes. Disconnected and reconnected again, ran it pretty hard and it seemed to work fine. Ran it slow and the Pede stopped again. Slow red again. I had the Venom LiPo in my pocket while I was running the stock so I chalked it up the battery being cold. Charged both batteries and the Venom only took approx. 2450ma. I have the Onyx 245 that displays how much current the battery took. So I started thinking about the whole waterproofing thing.....
    Here are my questions:
    1) Is the stock battery waterproof and the Venom not?
    2) Are all hard case batteries waterproof?
    3) What are some good options for a waterproof LiPo?

    Thanks in advance.
    Brian
    Last edited by brian.cline; 12-27-2012 at 08:32 PM. Reason: Found partial answer

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •